Why does the OpenDNS Updater show no IP address, and just below that the "Using OpenDNS?" says no. What do I do?

Comments

21 comments

  • Avatar
    rotblitz

    To see what's going wrong and how to fix it, post the complete plain text output of the following commands here: 
    (Trailing dots are part of the commands!)

    nslookup -type=txt debug.opendns.com. 208.67.220.220

    nslookup -type=txt which.opendns.com.

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    Chances are, the network hasn't been configured for OpenDNS (The Updater client won't do this by installing). See our router configuration instructions at https://support.opendns.com/forums/21618374 to get started.

    If you are unsure, you may run our diagnostic test tool and paste the output link here (it's only viewable by OpenDNS Staff).

    Mac http://www.opendns.com/download/mac/diagnostic
    Windows http://www.opendns.com/download/windows/diagnostic

    The URL should start with http://opendnsupdate.appspot.com/d/######.

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Avatar
    dtkhouse

    See results at https://diagnostic.opendns.com/d/5937209546899456  this is what I got - now what?

     

    0
    Comment actions Permalink
  • Avatar
    cobalt-phoenix

    Who should see the results? It's just you and OpenDNS staff.  If you want to have it served, you must open a support ticket with the link to the results.

    If you want to have quicker assistance from us users, you'd have to copy & paste the complete plain text output of the diagnostic commands listed above by RotBlitz.

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    Looks like you're not yet using OpenDNS - see https://support.opendns.com/forums/21618374 to configure it. 

     

    Results for: /usr/bin/dig +time=10 debug.opendns.com txt
    stdout:

    ; <<>> DiG 9.8.3-P1 <<>> +time=10 debug.opendns.com txt
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 15114
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;debug.opendns.com. IN TXT

    ;; AUTHORITY SECTION:
    opendns.com. 2703 IN SOA auth1.opendns.com. noc.opendns.com. 1457972452 16384 2048 1048576 2560

    ;; Query time: 16 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Mon Mar 14 21:35:19 2016
    ;; MSG SIZE rcvd: 81

    0
    Comment actions Permalink
  • Avatar
    airbendere

    Followed several other support threads and this one fixed my problem in 5 minutes.  Email me if you want a job in South Carolina.  Appreciate the great support help.

    -1
    Comment actions Permalink
  • Avatar
    4003jg

    I'm having same issue: https://diagnostic.opendns.com/d/5676446110449664

    My router has been correctly configure, yet I see no IP address and the Updater tool says USING OPENDNS? NO,

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    You have provided no information or data that will allow anyone to gain any insight into what is going on here. The link to the diagnostics do no good in this forum since they cannot be viewed by users here, only OpenDNS employees. Either open a support ticket and provide the diagnostics link in there or provide the results (the full results, not paraphrased results) of the following questions and diagnostic commands so that your fellow users can try to help after analyzing them

    What happens when you go to the following website? What message do you receive? http://welcome.opendns.com/

     

    If you are trying to block adult websites, what happens when you go to this website? http://www.exampleadultsite.com/

     

    Please copy and paste the complete output of the following commands. If you choose to provide a screenshot rather than pasting the text do not provide a link to a third party website since it's very possible that the security conscious people reading this forum have that domain blocked. Instead use the "Attach file" link at the bottom of this page. Note, the periods at the end of each command are part of the command, do not omit them or the results won't be usable for diagnostic purposes.

     

    nslookup -type=txt debug.opendns.com.

     

    nslookup www.exampleadultsite.com.

     

    ipconfig/all

    0
    Comment actions Permalink
  • Avatar
    glen

    I am having the same problem. 

     

     

     

    Here's the output:

     

    Last login: Wed Aug  9 08:09:04 on console

    iMac:~ mohr$ nslookup -type=txt debug.opendns.com. 208.67.220.220

    Server: 208.67.220.220

    Address: 208.67.220.220#53

     

    Non-authoritative answer:

    debug.opendns.com text = "server m8.nyc"

    debug.opendns.com text = "flags 20 0 50 3950000000000000000"

    debug.opendns.com text = "originid 99562249"

    debug.opendns.com text = "actype 2"

    debug.opendns.com text = "bundle 10228795"

    debug.opendns.com text = "source 24.34.249.1:35358"

     

    Authoritative answers can be found from:

     

    iMac:~ mohr$ nslookup -type=txt which.opendns.com.

    Server: 10.0.1.1

    Address: 10.0.1.1#53

     

    Non-authoritative answer:

    which.opendns.com text = "I am not an OpenDNS resolver."

     

    Authoritative answers can be found from:

     

    iMac:~ mohr$

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Same problem - same solution!

    Same as with the other cases above, your router behind 10.0.1.1 is not configured to use OpenDNS, so you're certainly using your ISP's DNS service instead.

    Again the link to the instructions for routers: https://support.opendns.com/hc/en-us/sections/206253627

    0
    Comment actions Permalink
  • Avatar
    glen

    Thanks. Have followed all instructions for configuring Airport Extreme using Airport Utility and DNS servers show the correct IP addresses.

    This test:

    • To test the Security Settings of your configuration, we recommend using the following test site to test blocking the Security setting for Phishing: http://www.internetbadguys.com. The desired outcome is to see: This domain is blocked due to a phishing threat.

    does show the correct result.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Is all good now?

    0
    Comment actions Permalink
  • Avatar
    glen

    Well, this page, https://welcome.opendns.com/, now says I am using OpenDNS (without me doing anything new - to be clear I had already followed the instructions and set router correctly before I started this thread). But the OpenDNS Updater status still looks like this (I blocked out my email):

     


    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    (I blocked out my email)

    What does this mean?  Can't you login to your OpenDNS account?  You must configure the Updater to authenticate with your account credentials, else it cannot do its job.

    If it is not this...

    Can the updater reach out via DNS (port 53) and HTTPS (port 443) to OpenDNS without being blocked by a firewall of any kind?

    Also, post the complete plain text outputs of the following diagnostic commands to here, from this Mac where you have the Updater running:

    nslookup -type=txt debug.opendns.com.
    nslookup myip.opendns.com.
    nslookup whoami.akamai.net.
    ifconfig -a -v (or similar syntax to display all network interface properties)

     

    0
    Comment actions Permalink
  • Avatar
    glen

    I meant that I whited out the emil so that it didn't display in the image I pasted here. Yes, the Updater is configured and I am logged in.

    Here are the outputs:

     

    ----------------------------------------------------------------------------------------------

    iMac:~ xxxx$ nslookup -type=txt debug.opendns.com.

    Server: 10.0.1.1

    Address: 10.0.1.1#53

     

    Non-authoritative answer:

    *** Can't find debug.opendns.com.: No answer

     

    Authoritative answers can be found from:

     

     

    ----------------------------------------------------------------------------------------------

     

    iMac:~ xxxx$ nslookup myip.opendns.com.

    Server: 10.0.1.1

    Address: 10.0.1.1#53

     

    ** server can't find myip.opendns.com.: NXDOMAIN

     

     

    ----------------------------------------------------------------------------------------------

    iMac:~ xxxx$ nslookup whoami.akamai.net.

    Server: 10.0.1.1

    Address: 10.0.1.1#53

     

    Non-authoritative answer:

    Name: whoami.akamai.net

    Address: 208.67.217.14

     

     

    ----------------------------------------------------------------------------------------------

     

    iMac:~ xxxx$ ifconfig -a -v

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384 index 1

    eflags=11000000<ECN_ENABLE,SENDLIST>

    options=3<RXCSUM,TXCSUM>

    inet6 ::1 prefixlen 128

    inet 127.0.0.1 netmask 0xff000000

    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1

    nd6 options=1<PERFORMNUD>

    link quality: 100 (good)

    state availability: 0 (true)

    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280 index 2

    eflags=1000000<ECN_ENABLE>

    state availability: 0 (true)

    stf0: flags=0<> mtu 1280 index 3

    eflags=1000000<ECN_ENABLE>

    state availability: 0 (true)

    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 index 4

    eflags=10009c0<ACCEPT_RTADV,TXSTART,RXPOLL,ARPLL,ECN_ENABLE>

    options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>

    ether 38:c9:86:33:d8:01

    inet6 fe80::3ac9:86ff:fe33:d801%en0 prefixlen 64 scopeid 0x4

    inet6 2601:19c:4800:a7b8:3ac9:86ff:fe33:d801 prefixlen 64 autoconf

    inet6 2601:19c:4800:a7b8:2d2a:bf93:a135:f7e0 prefixlen 64 autoconf temporary

    inet 10.0.1.43 netmask 0xffffff00 broadcast 10.0.1.255

    nd6 options=1<PERFORMNUD>

    media: autoselect (100baseTX <full-duplex,flow-control>)

    status: active

    type: Ethernet

    link quality: 100 (good)

    state availability: 0 (true)

    scheduler: QFQ

    link rate: 100.00 Mbps

    en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500 index 5

    eflags=1200080<TXSTART,NOACKPRI,ECN_ENABLE>

    ether 28:f0:76:27:a3:fa

    nd6 options=1<PERFORMNUD>

    media: autoselect (<unknown type>)

    status: inactive

    type: Wi-Fi

    state availability: 0 (true)

    scheduler: TCQ (driver managed)

    en2: flags=963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX> mtu 1500 index 6

    eflags=1000080<TXSTART,ECN_ENABLE>

    options=60<TSO4,TSO6>

    ether 1a:00:01:2b:6e:20

    media: autoselect <full-duplex>

    status: inactive

    type: Ethernet

    state availability: 0 (true)

    scheduler: QFQ

    en3: flags=963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX> mtu 1500 index 7

    eflags=1000080<TXSTART,ECN_ENABLE>

    options=60<TSO4,TSO6>

    ether 1a:00:01:2b:6e:21

    media: autoselect <full-duplex>

    status: inactive

    type: Ethernet

    state availability: 0 (true)

    scheduler: QFQ

    p2p0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 2304 index 8

    eflags=1020080<TXSTART,LOCALNET_PRIVATE,ECN_ENABLE>

    ether 0a:f0:76:27:a3:fa

    media: autoselect

    status: inactive

    type: Wi-Fi

    state availability: 0 (true)

    scheduler: TCQ (driver managed)

    link rate: 10.00 Mbps

    bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 index 9

    eflags=1000000<ECN_ENABLE>

    options=63<RXCSUM,TXCSUM,TSO4,TSO6>

    ether 3a:c9:86:33:8c:00

    Configuration:

    id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0

    maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200

    root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0

    ipfilter disabled flags 0x2

    member: en2 flags=3<LEARNING,DISCOVER>

            ifmaxaddr 0 port 6 priority 0 path cost 0

            hostfilter 0 hw: 0:0:0:0:0:0 ip: 0.0.0.0

    member: en3 flags=3<LEARNING,DISCOVER>

            ifmaxaddr 0 port 7 priority 0 path cost 0

            hostfilter 0 hw: 0:0:0:0:0:0 ip: 0.0.0.0

    nd6 options=1<PERFORMNUD>

    media: <unknown type>

    status: inactive

    state availability: 0 (true)

    awdl0: flags=8902<BROADCAST,PROMISC,SIMPLEX,MULTICAST> mtu 1484 index 10

    eflags=13e0080<TXSTART,LOCALNET_PRIVATE,ND6ALT,RESTRICTED_RECV,AWDL,NOACKPRI,ECN_ENABLE>

    ether be:b7:ce:4a:f9:da

    nd6 options=1<PERFORMNUD>

    media: autoselect

    status: inactive

    type: Wi-Fi

    state availability: 0 (true)

    scheduler: TCQ (driver managed)

    link rate: 10.00 Mbps

     

    And, in case it is helpful:

     


     


     


     

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You do not use OpenDNS currently, or at best randomly.  The reason may be that Comcast offers IPv6 connectivity, and your router uses also Comcast's DNSv6 server addresses, beside OpenDNS' DNSv4 addresses.  The solution would be to configure the following OpenDNS addresses as DNSv6 server addresses on the router:

    • ::ffff:d043:dedc
    • ::ffff:d043:dcde

    If this is not possible, try with configuring them on the computer under IPv6, or disable IPv6 connectivity altogether.

    Btw, the second and third screen shot are just for DHCP and LAN and therefore irrelevant.

    0
    Comment actions Permalink
  • Avatar
    molex1000

    Just wanted to chime in that after setting up openDNS on my Apple Airport Extreme on a Comcast connection it was not working, same as everyone else in this thread, but when I entered the IPv6 server addresses from rotblitz's post above into the IPv6 address fields in the Airport Utility program for my Airport Extreme it all started working right away.

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    @wangfineart

    Posting this link here is of no use.  We other users cannot access it.  You must open a support ticket with OpenDNS, referencing the link, so that staff can look after it.  Don't forget to describe what your problem is.

    If your problem is this:

    Why does the OpenDNS Updater show no IP address, and just below that the "Using OpenDNS?" says no. What do I do?

    then copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.

     

    0
    Comment actions Permalink
  • Avatar
    hellojohnbuck (Edited )

    If anyone can help I'd appreciate it.

    I have signed up for a paid plan.

    I set up my Router and clicked the "Test your device" icon and got the ✅

    but when I run the OpenDNS Update I also get the 'No' and the blocked domains and activities just go through...

    I have attached some screenshots and the Test results link.

    Report Link: https://diagnostic.opendns.com/d/5720299320901632

    macOS 11.6

    Firewall off

    Arcadyan Router from Broadband provider. Home install.

     

     

     

     

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.