OPENDNS not working

Comments

14 comments

  • Avatar
    Patrick Colford

    Hi there,

    The section "originid 0" lets us know that your IP address isn't registered. If you have an OpenDNS account, you'll want to use the Dynamic IP Updater client (https://support.opendns.com/entries/23282614-Where-do-I-download-an-OpenDNS-Dynamic-IP-updater-client-) to keep your registered network's IP address up to date. If you haven't registered a network, you'll have to do that to specify content filtering. We don't automatically block content, except for the FamilyShield resolvers.

    0
    Comment actions Permalink
  • Avatar
    rotblitz
    1. Ensure that you filled the 3rd DNS server field in DD-WRT with one of 208.67.222.220 or 208.67.220.222 at your router 192.168.1.1.
    2. Visit https://dashboard.opendns.com/settings/ to possibly add a network, to register your IP address 206.54.219.241 with it, and to configure your content filtering settings.
      And then run an Updater as Patrick said.

    As you have DD-WRT, you don't need to run the software Updater, but you can use the built-in Updater of DD-WRT instead. 
    See http://www.dd-wrt.com/wiki/index.php/OpenDNS

    0
    Comment actions Permalink
  • Avatar
    sudipr

    Thanks Guys!! I registered the IP  206.54.219.241. Also downloaded and installed Dynamic IP Updater. Did FlushDNS. But I still can go to 'Wrong' websites. What am I missing. Is there a preconfigured version for family protection out there which I am missing. I want to completely block PORN, PHISHING and other non-desirable websites

    SR

    0
    Comment actions Permalink
  • Avatar
    Patrick Colford

    Your network hadn't been verified yet, and so none of your filters were applying. I've verified your network, and it looks like your IP address updated. You may want to post the results of the nslookup to debug.opendns.com again so that we can confirm the IP address is registered correctly.

    0
    Comment actions Permalink
  • Avatar
    sudipr

    OK finally figured out that the FAMILYSHIELD DNS IP is different than what I am using. Updated the last 3 digits of the IP address to 123 and BINGO it works. Thanks!! 

    Y'all Rock

    SR

    0
    Comment actions Permalink
  • Avatar
    sudipr

    Patrick

    Even though it is working the way I want. But since you asked for it:

    C:\>nslookup -type=txt debug.opendns.com
    Server: DD-WRT
    Address: 192.168.1.1

    Non-authoritative answer:
    debug.opendns.com text =

    "server 1.ash"
    debug.opendns.com text =

    "flags 20 0 2F6 8027F00F1189EF3"
    debug.opendns.com text =

    "originid 24129441"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 6479815"
    debug.opendns.com text =

    "source 206.54.219.241:22982"

    Thanks

    SR

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    That looks good.  Your IP address 206.54.219.241 is registered with OpenDNS network ID 24129441 now.  You should find this number in the URL when visiting the settings for your network.  And you are served by the OpenDNS WDC data center.

    0
    Comment actions Permalink
  • Avatar
    sudipr

    Interesting.. With FamilyShield I can't even go to yahoo or google email. Is it by design? So if I go with non-Familyshield what should I do for my APPLE Airport express and dd-wrt flashed WRT54G. Now I am getting lost :(

    0
    Comment actions Permalink
  • Avatar
    sudipr

    I am shifting away from FamilyShield into normal OpenDNS. I have two routers. The reason being my home is fairly large and there are spots upstairs where we have dead zone. To circumvent I added a DD-WRT flashed router upstairs and all is great. Now I guess I can only configure one router not two. How do I add the second router to OpenDNS

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I only see your WRT54G from your output.  What role does the Apple Airport Express play?  How are these devices connected to each other and to the end user devices?

    "With FamilyShield I can't even go to yahoo or google email. Is it by design?"

    I would not be aware that these should be blocked.  And you shouldn't just say "yahoo" or "google".  This is highly unspecific for researches.  You better provide us with the full URL or at least the full domain and show the nslookup result for those.

    Also, did you flush both, your local resolver cache and your browser cache?

    0
    Comment actions Permalink
  • Avatar
    sudipr

    WRT54G is the backup for the dead spots I have upstairs. Airport express is our workhorse and all devices are mostly connected to it. It is only when we land up upstairs in the dead spots that we connect to WRT54G.

    With FamilyShield I cannot connect to mail.google.com

    C:\>nslookup -type=txt mail.google.com
    Server: UnKnown
    Address: 10.0.1.1

    Non-authoritative answer:
    mail.google.com canonical name = googlemail.l.google.com

     

    or mail.yahoo.com

    C:\>nslookup -type=txt mail.yahoo.com
    Server: UnKnown
    Address: 10.0.1.1

    Non-authoritative answer:
    mail.yahoo.com canonical name = login.yahoo.com
    login.yahoo.com canonical name = ats.login.lgg1.b.yahoo.com
    ats.login.lgg1.b.yahoo.com canonical name = ats.member.g02.yahoodns.net
    ats.member.g02.yahoodns.net canonical name = any-ats.member.a02.yahoodns.net

     

    Thanks

    SR

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "How do I add the second router to OpenDNS"

    Probably in the same way as the other?  You didn't say how this equipment is connected.

    "With FamilyShield I cannot connect to mail.google.com  ...  or mail.yahoo.com"

    These requests went through your router at 10.0.1.1 now.  Is this the Apple Airport Express?

    Then you have to raise the commands again, the debug.opendns.com with -type=txt, the others without.  The earlier commands were against your DD-WRT at 192.168.1.1.  You can force them to go through a certain router:

    nslookup -type=txt debug.opendns.com.  10.0.1.1
    nslookup mail.google.com.  10.0.1.1
    nslookup mail.yahoo.com.  10.0.1.1

    0
    Comment actions Permalink
  • Avatar
    sudipr

    Well With OpenDNS I can only configure one router not multiple in my dashboard

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You cannot configure a router at all, just an IP address.  And you got one IP address only from your ISP, did you?

    0
    Comment actions Permalink

Please sign in to leave a comment.