Can't get OpenDNS to work

Comments

11 comments

  • Avatar
    rotblitz

    "Have OpenDNS settings all setup but still not blocking pages."

    OpenDNS does not block web pages, but domains during DNS lookups.  OpenDNS is a DNS service, not a proxy.

    "Have set everything up just like it say in the family shield instructions."

    So you're saying you configured the FamilyShield addresses 208.67.222.123 and 208.67.220.123?  Then there's nothing to do else.  FamilyShield is "set and forget".  It seems you configured more, e.g. you registered your IP address 72.79.241.187 with OpenDNS network ID 2593679 at your dashboard.  This is not part of the FamilyShield instructions, but you can do this.

    Also, a bunch of questions:

    1. Where (on what device) did you configure the OpenDNS resolver addresses?  Is this on the D-Link DSL-2750B ?
    2. Did you get your D-Link DSL-2750B from Verizon, or is it OEM?
    3. Your local DNS on the computer points to 127.0.1.1, a localhost address.  What DNS server/forwarder is this?  Is it the dnscrypt-proxy or what?
    4. What message does http://welcome.opendns.com/ show up with?
    5. Do you have IPv6 connectivity enabled over the internet?
    0
    Comment actions Permalink
  • Avatar
    scroteau

    1. OpenDNS was configured on D-Link DSL-2750B

    2. D-Link DSL-2750B is from Verizon

    3. I don;t know how to answer this question. Could you provide so instructions as to how to get this information?

    4. I get the Opps You aren’t using OpenDNS yet.

        - Computer has been restarted

        -  Dns has been flush

        - Browser cache has been flushed

    5. IPv6 testing fails

    0
    Comment actions Permalink
  • Avatar
    rotblitz
    1. Post a screen shot from the router page where you have OpenDNS configured.
    2. ---
    3. Well, I expected your local DNS to be pointed to the router's IP address, but it points back to your local machine.  There must be a reason for this configuration, e.g. a program which forwards the DNS queries on to the router.  What Operating System do you run on this computer?  I can't provide you with instructions if I know nothing about your equipment.  If it is Windows, post the complete plain text output of "ipconfig /all".
    4. You see, your OpenDNS dashboard settings cannot take effect, because your browser doesn't send your DNS lookups to OpenDNS, but to another DNS service, ignoring your settings on the router and maybe the settings on the computer.  What browser do you use?
    5. How did you test IPv6?  Via a test tool at a website?  This wouldn't be the proof.  You have to check your computer's and router's network settings for IPv6 to find out.  The reason is: if you send out your DNS lookups via IPv6, then they go to OpenDNS only if you have configured OpenDNS IPv6 resolver addresses, but your dashboard settings don't take effect anyway, because you cannot register an IPv6 address at your dashboard.
    0
    Comment actions Permalink
  • Avatar
    scroteau

    Here is the screenshot of my router settings

     




    Verizon Management Console - Mozilla Firefox_001.png
    0
    Comment actions Permalink
  • Avatar
    rotblitz
    1. That's fine.
    0
    Comment actions Permalink
  • Avatar
    scroteau

    Here is ipconfig /all, This is from another computer on the LAN. All computer on LAN have same problem and are not using the DNS settup on the router.


    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Office-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : home

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : home
       Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
       Physical Address. . . . . . . . . : 00-1D-60-B5-1B-54
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::7585:9f8e:4d19:cbc1%8(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.65(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Thursday, August 28, 2014 6:01:54 AM
       Lease Expires . . . . . . . . . . : Thursday, September 04, 2014 6:10:30 AM
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : 201334112
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-3D-04-94-00-1D-60-B5-1B-54

       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 6:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 02-00-54-55-4E-01
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.home
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    0
    Comment actions Permalink
  • Avatar
    scroteau

    I am wondering if this might have something to do with the problem. On the Verizon Management Console under Internet there is a DNS that I can't change. Attached is a screenshot




    VerizonDslInternetSetup.png
    0
    Comment actions Permalink
  • Avatar
    scroteau


    C:\Users\scroteau>nslookup -type=txt which.opendns.com. 208.67.220.123
    Server:  resolver2-fs.opendns.com
    Address:  208.67.220.123

    Non-authoritative answer:
    which.opendns.com       text =

            "7.nyc"

    0
    Comment actions Permalink
  • Avatar
    scroteau

    If tried multiple devices

        - Windows Vista Machine

        - Window 7 Machine

        - Linux Mint

        - iPhone

     

    Multiple Browsers

        - Firefox

        - Chrome

        - Safari

        - Internet Explorer

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "On the Verizon Management Console under Internet there is a DNS that I can't change."

    This may well be the problem.  But, on the other hand, all your nslookup outputs confirm that your OSes are using OpenDNS, because you get response from OpenDNS.  Just your browsers don't seem to use your OS and router configuration for whatever reason... 
    http://welcome.opendns.com/ 

    I ran a bit out of ideas.  Maybe someone else?  Or open a support ticket.  OpenDNS staff have even more options to look into your problem.

    0
    Comment actions Permalink
  • Avatar
    vtech1

    I do not mean to thread necro but I am having the same issue on the same router. 

    Further digging through post seeming similar frustration. 

    0
    Comment actions Permalink

Please sign in to leave a comment.