OpenDNS Enchanted Features Not Working Properly On Network

Comments

19 comments

  • Avatar
    rotblitz

    This is because your IPaddress 189.30.32.230 is not registered with your OpenDNS network at https://dashboard.opendns.com/settings/ ("originid 0").

    You can correct this manually there by clicking the green arrows icon, or you have to run an Updater.  If you run the OpenDNS Updater, ensure that you have unchecked "Send Dns-O-Matic Updates".

    "a field name slot for PPoE Name or something like that; I also tried filling that slot"

    This is useless. Don't do it.

    "Then I went to the router and tried to follow Brian's suggestion"

    This is useless either, because you can't register IPv6 addresses at https://dashboard.opendns.com/settings/
    You generally cannot use IPv6 connectivity for DNS queries yet, because OpenDNS cannot associate your DNS queries with your account, so your settings cannot take effect.

    0
    Comment actions Permalink
  • Avatar
    digo26

    So, I ran an OpenDNS Updater on my home computer, with "Send Dns-O-Matic Updates" unchecked.

    It seemed to work fine for the first days, but today I was navigating the Internet and realized the filtering wasn't working at all. So I went to the Updater, and I see this red message:
    "Your OpenDNS filtering settings might not work due to DNS IP address (92.242.140.20) and HTTP IP address (177.4.53.141) mismatch."

    I could check "Send Dns-O-Matic Updates" again but last time it was checked, OpenDNS enchanted options didn't work as well. What do you suggest?

    0
    Comment actions Permalink
  • Avatar
    Chris Frost

    From my experience, this error usually indicates that a proxy is being run on your network. Do you know if you ISP is using a proxy? If you don't, I would recommend contacting them and asking if they currently run a transparent proxy (this is common). If they do, ask if you can be removed from it. Otherwise if you cannot, unfortunately OpenDNS will not work on your network. 

    0
    Comment actions Permalink
  • Avatar
    digo26

    Hello Chris Frost, thank you for your support.

    I contacted my ISP a few moments ago, and they actually said they just provide Internet Acess and proxy configurations were my problem. I would have to hire a private tecnician to take a look at my configurations, or do it myself. What do you recommend? Is it easy for myself to try and be removed from that transparent proxy?

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    With regards to the DNS-O-Matic updates checkbox, this is to send updates to a different service and therefore OpenDNS wouldn't update if this were checked. From the original content, 189.30.32.230 was your IP address.

    I have two checks to make. The first is to click "standard test" on http://dnsleaktest.com and report the result. The second is to run our diagnostic test from https://support.opendns.com/entries/21841580 and reply with the link which will allow us to check into this issue some more. 

    0
    Comment actions Permalink
  • Avatar
    digo26

    The first test you asked me:

    IPHostnameISPCountry
    201.10.4.3 none Oi Internet Brazil

    The second test:

    I don't know what domain you would like for me to run the test, so I selected Facebook and put the same ticket number as on the screenshot. This is the link:
    https://opendnsupdate.appspot.com/d/5613215165710336

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    But you said it worked for a while, so a proxy or something like that is rather unlikely.  Check at https://dashboard.opendns.com/settings/ what IP address is registered with your OpenDNS dashboard network.

    And here are two more tests to perform if you like:

    http://www.lagado.com/proxy-test 
    http://www.lagado.com/tools/cache-test

    Also, here a way to see your IP address the internet (and OpenDNS) sees from you:

    DNS IP address:  nslookup myip.opendns.com.  208.67.220.220 
    Web IP address:  http://myip.dnsomatic.com/

    They should be the same in an ideal case.  If not, the DNS IP address would need to be registered at https://dashboard.opendns.com/settings/

    0
    Comment actions Permalink
  • Avatar
    digo26

    It did work for a while. At this exact moment, the registered IP on my Dashboard is "177.4.53.141".

    I will perform every test, I am willing to solve this problem and will cooperate in any ways I can to help you identify the problem.

    Lagado Proxy Test results

    Remote   IP Address 177.4.53.141

    Request   Protocol HTTP/1.1   Method GET

    Request Headers

    Host

    www.lagado.com

    Connection

    keep-alive

    Accept

    text/html,​application/xhtml+xml,​application/xml;q=0.9,​image/webp,​*/*;q=0.8

    User-Agent

    Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.124 Safari/537.36

    DNT

    1

    Accept-Encoding

    gzip,deflate,sdch

    Accept-Language

    en-US,en;q=0.8,pt-BR;q=0.6,pt;q=0.4

    This Server   Host www.lagado.com   IP Address 27.131.76.84

    Date: Thursday 2 Oct 2014 2:14:48 GMT+1000

    Lagado Cache test results

    So, the page serial number changed from “334428” to “334431”, so I may not be using a caching proxy. Then I checked the page age (I think my workstation time is accurate). It revealed 4 seconds.

    If the page age is no more than a few seconds there is no evidence of caching occuring so a proxy is not evident; stop here - No Proxy Found

    -----

    Then I checked the things you said:

    DNS IP adress on command prompt:
    Server: resolver2.opendns.com
    Address: 208.67.220.220.

    Non-autoritative answer:
    Name: myip.opendns.com
    Address: 177.4.53.141

    Then I went to the link "http://myip.dnsomatic.com/" and this is what I found:
    177.4.53.141

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    This looks all good, most likely no proxy, no caching, no NAT.

    Therefore "this red message:
    "Your OpenDNS filtering settings might not work due to DNS IP address (92.242.140.20) and HTTP IP address (177.4.53.141) mismatch." in the Updater was rather an Updater bug...

    So, going back to the original problem "OpenDNS is working but not the enchanted features, like customizable filtering and such".

    As of your original "nslookup -type=txt debug.opendns.com.", your IP address information was clearly not registered with OpenDNS at this time.  Now, as it is registered, everything should work.  If not, flush your caches again, both local resolver cache and browser cache.

    And if you continue to have problems with the Updater, uninstall it and use another like http://updater.marc-hoersken.de/

    If you continue to have problems with the enchanted features, you'll have to wait for OpenDNS staff coming back with the results from your diagnostics.

    Just one thing, if your router has more than two DNS entries, fill them all with OpenDNS resolver addresses.  Here are two more: 208.67.222.220 and 208.67.220.222.

    0
    Comment actions Permalink
  • Avatar
    digo26

    Nope, flushed both with "ipconfig /flushdns" and browser cache and still not working.

    I downloaded Marcs Updater. I'm not sure it is correctly configured, I couldn't find any configurations instructions on Marc's site. I entered my OpenDNS account email on the "username" slot. If I check the options for Local Network filtering and Wireless filtering, then the Updater doesn't authenticate - nothing happens. So, those options are unchecked for it to authenticate. After authentication, I flushed prompt and browser caches, and nothing changed.

    My router does not have any more DNS entries, only two.

    0
    Comment actions Permalink
  • Avatar
    digo26

    Also, I'm not sure wheter this is a valuable information or not, but for now not even basic OpenDNS features are working. I went to http://www.opendns.com/welcome/ and I see the red X with the "Oops'' message. I checked my router and OpenDNS values are still there.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You maybe have non-OpenDNS resolvers configured on your computer.  If this is Windows, post the output of the following commands (again):

    nslookup -type=txt debug.opendns.com.
    ipconfig /all

    0
    Comment actions Permalink
  • Avatar
    digo26

    It is Windows. Here are the outputs:

    For the first:
    Server: dsldevice.lan
    Address: 192.168.1.1

    *** dsldevice.lan did not find debug.opendns.com.: Non-existent domain

    The second command (it is in Portuguese because I copied it and my computer is in Portuguese):

    C:\WINDOWS\system32>ipconfig /all

    Configuração de IP do Windows

    Nome do host. . . . . . . . . . . . . . . . : Paulo_Rogério
    Sufixo DNS primário . . . . . . . . . . . . :
    Tipo de nó. . . . . . . . . . . . . . . . . : híbrido
    Roteamento de IP ativado. . . . . . . . . . : não
    Proxy WINS ativado. . . . . . . . . . . . . : não

    Adaptador de Rede sem Fio Conexão Local* 12:

    Estado da mídia. . . . . . . . . . . . . . : mídia desconectada
    Sufixo DNS específico de conexão. . . . . . :
    Descrição . . . . . . . . . . . . . . . . . : Adaptador Virtual Direto Wi-Fi
    da Microsoft
    Endereço Físico . . . . . . . . . . . . . . : 1E-C9-D3-19-65-A8
    DHCP Habilitado . . . . . . . . . . . . . . : Sim
    Configuração Automática Habilitada. . . . . : Sim

    Adaptador Ethernet Ethernet:

    Estado da mídia. . . . . . . . . . . . . . : mídia desconectada
    Sufixo DNS específico de conexão. . . . . . :
    Descrição . . . . . . . . . . . . . . . . . : Realtek PCIe GBE Family Control
    ler
    Endereço Físico . . . . . . . . . . . . . . : 74-D0-2B-6F-53-A1
    DHCP Habilitado . . . . . . . . . . . . . . : Sim
    Configuração Automática Habilitada. . . . . : Sim

    Adaptador de Rede sem Fio Wi-Fi 2:

    Sufixo DNS específico de conexão. . . . . . :
    Descrição . . . . . . . . . . . . . . . . . : Qualcomm Atheros AR9485 Wireles
    s Network Adapter
    Endereço Físico . . . . . . . . . . . . . . : 5C-C9-D3-19-65-A8
    DHCP Habilitado . . . . . . . . . . . . . . : Sim
    Configuração Automática Habilitada. . . . . : Sim
    Endereço IPv6 de link local . . . . . . . . : fe80::9d24:e578:b1f7:8645%3(Pre
    ferencial)
    Endereço IPv4. . . . . . . . . . . . . . . : 192.168.1.5(Preferencial)
    Máscara de Sub-rede . . . . . . . . . . . . : 255.255.255.0
    Concessão Obtida. . . . . . . . . . . . . . : quinta-feira, 2 de outubro de 2
    014 17:02:56
    Concessão Expira. . . . . . . . . . . . . . : sexta-feira, 3 de outubro de 20
    14 18:54:17
    Gateway Padrão. . . . . . . . . . . . . . . : 192.168.1.1
    Servidor DHCP . . . . . . . . . . . . . . . : 192.168.1.1
    IAID de DHCPv6. . . . . . . . . . . . . . . : 257739219
    DUID de Cliente DHCPv6. . . . . . . . . . . : 00-01-00-01-1A-0E-79-0A-74-D0-2
    B-6F-53-A1
    Servidores DNS. . . . . . . . . . . . . . . : 192.168.1.1
    NetBIOS em Tcpip. . . . . . . . . . . . . . : Habilitado

    Adaptador de túnel Conexão Local* 13:

    Sufixo DNS específico de conexão. . . . . . :
    Descrição . . . . . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interfa
    ce
    Endereço Físico . . . . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Habilitado . . . . . . . . . . . . . . : Não
    Configuração Automática Habilitada. . . . . : Sim
    Endereço IPv6 . . . . . . . . . . : 2001:0:43d7:4182:3455:1880:3f57:fefa(Pref
    erencial)
    Endereço IPv6 de link local . . . . . . . . : fe80::3455:1880:3f57:fefa%6(Pre
    ferencial)
    Gateway Padrão. . . . . . . . . . . . . . . : ::
    IAID de DHCPv6. . . . . . . . . . . . . . . : 150994944
    DUID de Cliente DHCPv6. . . . . . . . . . . : 00-01-00-01-1A-0E-79-0A-74-D0-2
    B-6F-53-A1
    NetBIOS em Tcpip. . . . . . . . . . . . . . : Desabilitado

    Adaptador de túnel isatap.{D584E976-1757-4AA0-AF41-19E4ABFF38D3}:

    Estado da mídia. . . . . . . . . . . . . . : mídia desconectada
    Sufixo DNS específico de conexão. . . . . . :
    Descrição . . . . . . . . . . . . . . . . . : Adaptador do Microsoft ISATAP #
    2
    Endereço Físico . . . . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Habilitado . . . . . . . . . . . . . . : Não
    Configuração Automática Habilitada. . . . . : Sim

    C:\WINDOWS\system32>ipconfig /all

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Well, now I know that "Sim" in Portuguese means "Yes".  :)

    Your computer uses the "Qualcomm Atheros AR9485 Wireless Network Adapter" named "Adaptador de Rede sem Fio Wi-Fi 2" and sends your DNS queries to the router at 192.168.1.1, this DNS server address as the only one having been obtained via DHCP from the router, as can be seen from ipconfig.  So everything DNS specific has to happen on the router which has to forward the DNS queries to OpenDNS.

    Your nslookup output confirms that the router didn't use OpenDNS at all at this time: "dsldevice.lan did not find debug.opendns.com.: Non-existent domain".  Only OpenDNS can resolve that domain, so your query went to another DNS service, not OpenDNS.

    I have checked your user manual from http://downloads.trendnet.com/tew-658brm/manual/tew-658brm(v1.0r).pdf
    This is a very advanced router with everything one may need, but its configuration is not trivial.
    Or did I pick the wrong manual?

    What settings have you selected for "DNS Enabled" and "DNS Override Allowed" on your internet connection page?  You may play around with these values to see if it resolves your problem with not using OpenDNS.  And you may post a screen shot ot this router page.

    Also, in the DHCP settings, what IP addresses are configured for "Primary DNS Server" and "Secondary DNS Server"?  This takes effect only if the "DNS Relay" option in the LAN settings is enabled.  Is it enabled?

    Just by chance, do you use multi-WAN and have this enabled?  Or have you VPN passthrough enabled which could impact the use of OpenDNS?

    0
    Comment actions Permalink
  • Avatar
    digo26

    Here's a screenshot. This is how it is at 1 PM at October 6th. "DNS Override Allowed" was disabled, now it is enabled - let's see what happens.

    I took a screenshot of LAN settings page on router as well. Take a look.

    I'm not sure about using multi-WAN or not, nor about VPN. May you tell me how do I know if I am using it?




    router screenshot.jpg
    lan settings.jpg
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Let's first see if it works now with your current settings.

    0
    Comment actions Permalink
  • Avatar
    digo26

    Flushed resolver and browser caches and nothing happened.

    0
    Comment actions Permalink
  • Avatar
    digo26

    Also, I configured OpenDNS addresses on DNS entries of my Local Connection. This way, OpenDNS and enchanted features are working on my laptop, but still not on my Wireless Network. Maybe this is valuable information.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    This behaviour is to be expected.  If you configure something on an end user device, it cannot affect the whole network but just this device.

    0
    Comment actions Permalink

Please sign in to leave a comment.