Dynamic IP and Open DNS servers?

Comments

8 comments

  • Avatar
    Patrick Colford

    Hi there,

    If you got your router from your ISP, they may have changed the firmware on it so that the DNS servers can't be changed. You can ask them to "bridge" the device and use a secondary router behind it that can be configured instead if configuring the individual devices isn't something you're interested in, but that would be the most certain way of configuring your home to use OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    treally

    Thanks for the fast reply!  Actually, I just bought a new router,  it is not the ISP's.  With the ISP's I was able to point the DNS settings to Open DNS.  For some reason on this router (TL-WR841N) I can't.  Every time I enter the server address for Open DNS the router defaults right back to the ISP's.

    0
    Comment actions Permalink
  • Avatar
    Patrick Colford

    There's at least one older thread about this problem here: https://forums.opendns.com/comments.php?DiscussionID=16943

    In that thread, it was revealed that the user's ISP was switching the DNS entries back, so you may want to ask them just in case, but it doesn't seem likely here given what you've described. Is the router's firmware up to date? 

    0
    Comment actions Permalink
  • Avatar
    treally

     It does need a firmware update I noticed (thanks-I haven't had a chance to do it yet),  I will do that this evening and see if that remedies the problem. 

     

    Thanks again for your help and advice.

    0
    Comment actions Permalink
  • Avatar
    treally

    So I upgraded the firmware and added the Open DNs Server addresses into the router, but still no filtering/blocking.  This function worked in the past so I am at a loss as to why it isn't functioning anymore.  I also cleared the DNS cache and the Browsers cache.

    Any help would be appreciated.

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    One way to test the final destination of the DNS requests is by running the test at http://dnsleaktest.com. To check for ISP interaction, configure your computer directly (https://support.opendns.com/forums/21618384) and then run the leak test and see if the final result is OpenDNS. If not, there is likely ISP involvement. 

    0
    Comment actions Permalink
  • Avatar
    treally

    Thanks Alexander!  I followed your suggestion and performed the leak test(I used the extended test btw).  The test showed involvement from my anti-virus software(Avast-Paid version).  I had no idea they were involved with DNS(Must have been a fairly recent update).  I dug into the settings a bit and turned off a setting (Secure DNS).  Everything works now, all of the devices in my house are covered by the Open DNS  server addresses in the router. 

     

    Thanks again

    0
    Comment actions Permalink
  • Avatar
    Alexander Harrison

    I'm glad to hear that the leak test was able to guide you in the right direction. For anyone who may see this thread in the future and not connect the dots, we've written up an article on Avast's new secure DNS feature which auto-sets your DNS to  Avast's DNS: https://support.opendns.com/entries/57943894-Avast-2015-Security-Suite-Secure-DNS-and-OpenDNS

    We're glad to help!

    0
    Comment actions Permalink

Please sign in to leave a comment.