fetchstats throwing "Login failed" error with correct password

Comments

9 comments

  • Avatar
    Daniel Cheung

    Hello zygykoz!

    Could you let me know if you're also having any trouble logging in with your username and password on you Dashboard?

    0
    Comment actions Permalink
  • Avatar
    zygykoz

    No issue logging into the Dashboard site at all. (verified on 3 different browsers across linux/windows boxes: IE, firefox, chrome)

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Your password must not contain special characters reserved for URL encoding, or you must escape such characters.

    0
    Comment actions Permalink
  • Avatar
    zygykoz
    No special characters.

    I was finally able to get it to work.

    I used my actual chosen network readable name instead of the ID and it finally worked. So the command was:

    "bash fetchstats email@domain.com Name 2015-06-22 2015-06-25"

    Prompted for my personal and showed the data. Added the > file.csv command and was cooking with butter.

    Very strange since anything I came across online said to use the network ID from your dashboard URL. The all command didn't work either, and I know last time I used it (years back) the name did not work and I had to use the ID.

    Either way I'm good now, thanks to those that responded! Cheers!
    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Not really sure what you mean by "network readable name", but if this is your self-selected network label from https://dashboard.opendns.com/settings/ - this works under no circumstances and is instructed nowhere.  And yes, you must use the numeric network ID.  No idea why "all" doesn't work too, although it should.

    No matter, happy to hear that it works for you now.

    0
    Comment actions Permalink
  • Avatar
    zygykoz
    Yes, I have to use the self-selected network label. And yes exactly why I found it so surprising that it works only using my label, and my network ID fails....
    0
    Comment actions Permalink
  • Avatar
    not_4_the_public

    I had the same issue with the bash file. I made some little changes and now it works.

    You can find the script at https://pastebin.com/jscQP6FH.

     

    0
    Comment actions Permalink
  • Avatar
    guraaf

    not_4_the_public - the pastebin is no longer available and I am wondering what was the fix. I am trying to use the bash script on my MacOS and running into login/password problems. I did print (echo) the password in the script and see that it gets converted to %hex value for all characters so that looks like a smart idea to protect against special characters. However, no luck logging in. Thanks!

    0
    Comment actions Permalink
  • Avatar
    not_4_the_public

    Hello Guraaf,

    The original post I had saved and did place it again on pastebin. The url is : https://pastebin.com/7SDMx3TQ. I hope it will solve you issue.

    Goof luck

    0
    Comment actions Permalink

Please sign in to leave a comment.