Opendns Family Shield is unable to block porn sites.

Comments

14 comments

  • Avatar
    rotblitz

    Because your DNS traffic goes over IPv6?  In this case you must disable IPv6 connectivity.

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    Thanks for the reply mate.

    I have disabled the ipv6 connectivity of my PC. But, still I am able to access the site.

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Ok, then copy and paste the complete plain text outputs of the following diagnostic commands here:

       nslookup -type=txt debug.opendns.com.

       nslookup www.exampleadultsite.com.

       nslookup www.videosexarchive.com.

       ipconfig /all

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    nslookup -type=txt debug.opendns.com

    Server:  resolver1-fs.opendns.com
    Address:  208.67.222.123

    Non-authoritative answer:
    debug.opendns.com       text =

            "server 9.sin"
    debug.opendns.com       text =

            "flags 20 0 70 1950800780000000000"
    debug.opendns.com       text =

            "originid 0"
    debug.opendns.com       text =

            "actype 0"
    debug.opendns.com       text =

            "source ***.**.***.**:*****"   (edited public ip with stars).



    nslookup www.exampleadultsite.com

    Server:  resolver1-fs.opendns.com
    Address:  208.67.222.123

    Non-authoritative answer:
    Name:    www.exampleadultsite.com
    Addresses:  146.112.61.106
              146.112.61.106



    nslookup www.videosexarchive.com.

    Server:  resolver1-fs.opendns.com
    Address:  208.67.222.123

    Name:    www.videosexarchive.com
    Address:  183.82.14.10



    Ipconfig /all ----I have omitted results related with my PC..

    DNS Servers . . . . . . . . . . . : 208.67.222.123
                                                     208.67.220.123

    nslookup -type=txt debug.opendns.com

    Server:  resolver1-fs.opendns.com
    Address:  208.67.222.123

    Non-authoritative answer:
    debug.opendns.com       text =

            "server 9.sin"
    debug.opendns.com       text =

            "flags 20 0 70 1950800780000000000"
    debug.opendns.com       text =

            "originid 0"
    debug.opendns.com       text =

            "actype 0"
    debug.opendns.com       text =

            "source ***.**.***.**:*****"   (replaced public ip with stars).



    nslookup www.exampleadultsite.com

    Server:  resolver1-fs.opendns.com
    Address:  208.67.222.123

    Non-authoritative answer:
    Name:    www.exampleadultsite.com
    Addresses:  146.112.61.106
              146.112.61.106


    nslookup www.videosexarchive.com.

    Server:  resolver1-fs.opendns.com
    Address:  208.67.222.123

    Non-authoritative answer:
    Name:    www.exampleadultsite.com
    Addresses:  146.112.61.106
              146.112.61.106



    Ipconfig /all ----I have omitted results related with my lan.

    DNS Servers . . . . . . . . . . . : 208.67.222.123
                                        208.67.220.123

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    Sorry, by mistake i have copied a wrong output after the first four commands

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    I am unable to delete/edit my comments as their is no option for it.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "I have omitted results related with my lan."

    Then it is not a good idea to seek for help in a public forum...

    This is weird, for www.videosexarchive.com 183.82.14.10 is returned for you, although their IP address is worldwide 74.117.180.88.  And 183.82.14.10 has not a web service hosted, but is a dynamic DSL IP address in India.  So the domain be "blocked" for you anyway.

    For me OpenDNS does not return 183.82.14.10.  So it is either a problem with the Singapore data center, or it's a problem with your configuration, e.g. some protection software running on your PC.

    Best would be to raise a support ticket with OpenDNS with a link to this thread.

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    I mean I have omitted results of my PC like mac address, my pc lan Ip, time and date and gateway. there is nothing important omitted which is related with network settings.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    It may not appear important for you, but maybe for others attempting to help you.  And there is no reason to hide this information, because this is not security relevant.

    No matter, the question is why you get 183.82.14.20 returned instead of 74.117.180.88 or hit-adult.opendns.com.  I suspect that it is not OpenDNS returning this, but something else intercepting your DNS traffic.

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    I have checked other adult websites they are getting blocked by opendns but somehow this website which i have mentioned is not getting blocked. Do you think that there is security/privacy issue with my traffic. If yes, then what steps should I take further.

    If my dns traffice is getting intercepted than all the traffic should also get intercepted. But as you know only a single website is getting intercepted. It would be great if you shed some more light on this issue

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I did say nothing about a security/privacy issue with your DNS traffic.  You must have misunderstood me.  And traffic interception is always possible (and often done) by many ISPs.  The only way around is to use a VPN service.  If it comes to DNS, then http://dnscrypt.org/ is an option.

    I do not believe that this problem with the mentioned site can be resolved by users in this public forum.  Follow my suggestion to open a support ticket with a link to this thread.  As I said too, it could be a glitch with the OpenDNS Singapore data center.  Or it is something on your end.

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    "I did say nothing about a security/privacy issue with your DNS traffic.  You must have misunderstood me."

    To be on the cautious side, I was just asking about your opinion.

     

    "I do not believe that this problem with the mentioned site can be resolved by users in this public forum.  Follow my suggestion to open a support ticket with a link to this thread.  As I said too, it could be a glitch with the OpenDNS Singapore data center.  Or it is something on your end."

    I have checked with my default ISP dns servers. It is also showing the same nslookup output as it was with Opendns servers.

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    Assuming that your purged your DNS cache that indicates that the issue has nothing to do with OpenDNS. The issue likely lies with something that your ISP is doing with DNS traffic, or perhaps an indication that the domain owner is doing something very strange with it's DNS

    0
    Comment actions Permalink
  • Avatar
    nameuser1

    Thanks mattwilson9090. I think that might be the issue.

    Thanks for the support rotblitz. I appreciate your concern and replies to my thread. It was a good learning experience.

    0
    Comment actions Permalink

Please sign in to leave a comment.