[closed] Router home page shows "Parental Controls Status: Not Enabled"

Comments

8 comments

  • Avatar
    rotblitz

    As your "Router home page shows "Parental Controls Status: Not Enabled"", LPC is not enabled.  If you cannot enable it via login at http://routerlogin.net/, you must find another way to enable it with a device where Genie is supported, Windows, Mac OSX, iOS or Android.
    http://www.netgear.com/home/discover/apps/genie.aspx

    "I am told that LPC and OpenDNS shouldn't be used in conjunction. But if router DNS are set to OpenDNS IP address, the filtering works!"

    Yes, because you do not use LPC, but normal OpenDNS Home in this case.

    Another problem is that you use a DNS service built-in in your Linux, as can be seen from the configured localhost DNS server 127.0.1.1.  And the forwarders on this internal DNS server are not configured to reach OpenDNS at all.  Your outputs above indicate that your DNS queries didn't reach OpenDNS at this time.  In case of LPC the forwarders must point to your router, in case of OpenDNS Home the forwarders must point to either the router (if you configured the OpenDNS resolver addresses there) or directly to OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    akprashant

    Thanks for responding.

    It was confusing to have 3 variations of the same product, Netgear LPC, OpenDNS's FamilyShield and OpenDNS's Home.

    I have done further Observations, so just to make it comprehensive, request to comment/add info on them.

    1. If the router's DNS is manually set to OpenDNS's Family Shield Nameservers, then filtering is only limited to adult content and phishing websites. The router home page would however displaying that the "Parental Controls Status: Enabled" but LPC would not work according to the filtering level set at https://netgear.opendns.com.
    2. If the router's DNS is manually set to OpenDNS's Home Nameservers, nothing was being blocked, meaning adult content and phishing websites was also allowed. However the router home page would falsely displaying that the "Parental Controls Status: Enabled". Surprising and to be noted that merely relying on www.opendns.com/welcome and  www.InternetBadGuys.com would lead to false negative filtering.
    3. I tried to enable LPC via Android Genie app. It automatically modified the router DNS to OpenDNS nameservers and probably modified some other parameters on the router that are not apparent in the router home page. Found that LPC was working to the customised filtering set by me at https://netgear.opendns.com.

    Conclusion: To enable LPC, it is must to do via Genie and is the only known procedure. Merely setting the router's DNS to OpenDNS values wouldn't do it. The staus displayed on the  router homepage about "Parental Controls Status" is not reliable. In all the above cases, Geneie app correctly displays that LPC was enabled only on case3 and disabled in case 1 & 2.

    OpenDNS's FamilyShield nameservers:
    208.67.222.123
    208.67.220.123

    OpenDNS's Home nameservers:
    208.67.222.222
    208.67.220.220

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    If you are able to enable and to use LPC, you must not configure any OpenDNS resolver addresses manually.  This and more is what LPC does for you.  Your LPC dashboard is only at https://netgear.opendns.com/ - do not use the normal dashboard and delete any network you may have configured at https://dashboard.opendns.com/settings/

    If you do not or cannot enable LPC, then you can use the normal OpenDNS, no matter if FamilyShield or Home, and no matter if with your dashboard at https://dashboard.opendns.com/settings/ or not.

    With LPC not enabled and if you use and configure the dashboard at https://dashboard.opendns.com/settings/, then these settings take effect, with FamilyShield and Home.  However, FamilyShield always blocks adult domains and proxy/anonymizer domains, regardless of your dashboard settings.  For example, whitelisting an adult domain at your dashboard would not take effect, but most other kind of configuration would take effect.

    Also, never ever try to use LPC and normal OpenDNS at the same time.  These are not compatible!  You must go for the one or the other.

    The related KB article: https://support.opendns.com/entries/42423390

    And btw, there are four OpenDNS Home resolver addresses:
    208.67.222.222
    208.67.220.220
    208.67.222.220
    208.67.220.222

    "The status displayed on the router homepage about "Parental Controls Status" is not reliable."

    This may well be but is solely a Netgear issue.  You had to contact Netgear support for this.  It is unrelated to OpenDNS.

    "In all the above cases, Geneie app correctly displays that LPC was enabled only on case3 and disabled in case 1 & 2."

    Yes, this sounds consistent and as should be.

    0
    Comment actions Permalink
  • Avatar
    jwirick

    I am having a similar problem.  I have my router DNS settings AND my PC DNS settings set to 208.67.222.222 and 208.67.220.220 and this is what my nslookup command shows:

    Server:  resolver1.ipv6-sandbox.opendns.com
    Address:  2620:0:ccc::2

    debug.opendns.com    text =

        "server 9.ash"
    debug.opendns.com    text =

        "flags 20 0 0 1800000000000000000"
    debug.opendns.com    text =

        "originid 0"
    debug.opendns.com    text =

        "actype 0"
    debug.opendns.com    text =

        "source [2001:0:9d38:6ab8:2890:3d3b:9f08:69ee]:58805"

    It is not blocking ANY adult sites for some reason... I am relatively new to using OpenDNS but I KNOW it SHOULD work (user error though)

    THANKS!

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    If you are not using a Netgear router with LPC then you most definitely are NOT having a similar problem and you need to post in a thread that is not about LPC, or you need to start a thread of your own since this thread is about troubleshooting an LPC issue, not an OpenDNS Home issue.

    If you are using a Netgear router with LPC then you have it configured completely wrong if you want to be using LPC. First, to use LPC you do NOT configure the OpenDNS addresses on either your router or your PC. You configure LPC only, and use DHCP to have your PC point to the router for DNS. You would also need to configure all settings you did on your PC's and the rest of the network, as well as anything you configured at https://dashboard.opendns.com/settings/. Your dashboard is ONLY at https://netgear.opendns.com/

    I have no idea why you decided to use that particular command to test, but it also indicates that you have IPv6 configured for your internet connection. OpenDNS does not filter via IPv6, so if you want to use OpenDNS Home or LPC you have to disable IPv6 on either the router, or on every single device on your network. It's much simpler, and better for your LAN, to just disable IPv6 at the router.

    0
    Comment actions Permalink
  • Avatar
    akprashant

    @rotblitz: Though late could you tag this thread as "Answered". Thanks for the timely help.

    Note to realize that I didn't when this tread was created: Netgear's LPC can be enabled only via the proprietary Genie App http://www.netgear.com/home/discover/apps/genie.aspx . Fiddling with the web-GUI of the router alone wouldn't help.

    Just another comparison of features:

    1. I found that Netgear's LPC was more reliable than OpenDNS Home  because it does not allow bypassing specific client devices by changing their DNS settings. The Genie app with a bypass account needs to be configured on clients that need bypass access.
    2. The feature missing in Netgear's LPC https://netgear.opendns.com/ is the stats & logs of the DNS requests made which is available only if OpenDNS Home service https://dashboard.opendns.com is used instead.

    For reasons that has nothing to do with Netgear's LPC, I have began to use DD-WRT, an after market router firmware with OpenDNS Home service. http://dd-wrt.com/phpBB2/viewtopic.php?t=303441

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @j-dogg  
    It doesn't look like you using Netgear Live Parental controls, so please open your own thread in the Community Help section of the forum. 
    Just this: you must disable IPv6 connectivity on the router or on the devices to make it work, because your DNS traffic goes over IPV6, and the enhanced features of OpenDNS are supported with IPv4 only yet.

    @akprashant 
    I'm a user like you and have no way to do anything of what you have asked me to do.

    0
    Comment actions Permalink
  • Avatar
    akprashant

    @rotblitz: I just wanted the thread to be closed as it is solved the issue. As I observed that you are very active in the forums helping the members, so I wrongly assumed you to be a support staff from OpenDNS. Sorry for that. However, thank you for the dedicated time that you spend for the community.

    0
    Comment actions Permalink

Please sign in to leave a comment.