Draytek 2760

Comments

20 comments

  • Avatar
    rotblitz

    Step by step???  There's only one step!

    You enter the OpenDNS resolver addresses 208.67.222.222 and 208.67.220.220 into the yellow marked fields.


    Also ensure that you have IPv6 connectivity disabled, because the enhanced OpenDNS features do not work over IPv6 yet.

    Still baffled?

    0
    Comment actions Permalink
  • Avatar
    open16

    Yes I am

     

    I had done that

    but still get this:

    I am totally baffled! Any ideas?

    Thanks for getting back to me btw

     

    0
    Comment actions Permalink
  • Avatar
    open16

    and this is what I see when I do a network scan using my iPhone

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Now copy & paste the complete plain text output of the following diagnostic commands here:

    nslookup -type=txt debug.opendns.com.

    nslookup whoami.akamai.net.

    ipconfig /all

    Also, I'm baffled too.  You have "Specify an IP address" checked without having given an IP address.  Did you get a dynamic or a static IP address from your ISP?

    0
    Comment actions Permalink
  • Avatar
    open16

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com.nslookup whoami.akamai.net.ipconfig /all
    Usage:
       nslookup [-opt ...]             # interactive mode using default server
       nslookup [-opt ...] - server    # interactive mode using 'server'
       nslookup [-opt ...] host        # just look up 'host' using default server
       nslookup [-opt ...] host server # just look up 'host' using 'server'

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com.
    Server:  resolver1.opendns.com
    Address:  208.67.222.222

    Non-authoritative answer:
    debug.opendns.com       text =

            "server m6.lon"
    debug.opendns.com       text =

            "flags 20 0 70 5950800000000000000"
    debug.opendns.com       text =

            "originid 0"
    debug.opendns.com       text =

            "actype 0"
    debug.opendns.com       text =

            "source 86.131.211.150:54822"

    C:\WINDOWS\system32>

    0
    Comment actions Permalink
  • Avatar
    open16


    C:\WINDOWS\system32>nslookup whoami.akamai.net.
    DNS request timed out.
        timeout was 2 seconds.
    Server:  UnKnown
    Address:  208.67.222.222

    DNS request timed out.
        timeout was 2 seconds.
    *** Request to UnKnown timed-out

    C:\WINDOWS\system32>

    0
    Comment actions Permalink
  • Avatar
    open16


    C:\WINDOWS\system32>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : lenovo
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Mixed
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Ethernet:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Qualcomm Atheros AR8172/8176/8178 PCI-E Fast Ethernet Controller (NDIS 6.30)
       Physical Address. . . . . . . . . : 20-1A-06-A3-51-61
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Local Area Connection* 3:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
       Physical Address. . . . . . . . . : 74-DA-38-8B-EF-AA
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wi-Fi 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom 802.11n Network Adapter
       Physical Address. . . . . . . . . : 48-5A-B6-D5-C0-C7
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wi-Fi:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : 150Mbps Wireless 802.11bgn Nano USB Adapter
       Physical Address. . . . . . . . . : 74-DA-38-8B-EF-AA
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.22(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 01 December 2016 16:33:07
       Lease Expires . . . . . . . . . . : 02 December 2016 16:33:07
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 208.67.222.222
                                           208.67.220.220
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Ethernet 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : TAP-Windows Adapter V9
       Physical Address. . . . . . . . . : 00-FF-69-ED-48-16
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    C:\WINDOWS\system32>

    0
    Comment actions Permalink
  • Avatar
    open16

    SORRY FORGET ALL THE ABOVE

     

    0
    Comment actions Permalink
  • Avatar
    open16

    Because Open DNS is setup on this PC so I will do again

    0
    Comment actions Permalink
  • Avatar
    open16


    C:\>nslookup -type=txt debug.opendns.com.
    Server:  indnsc45.ukcore.bt.net
    Address:  213.120.234.54

    *** indnsc45.ukcore.bt.net can't find debug.opendns.com.: Non-existent domain

    C:\>

    0
    Comment actions Permalink
  • Avatar
    open16


    C:\>nslookup whoami.akamai.net.
    DNS request timed out.
        timeout was 2 seconds.
    Server:  UnKnown
    Address:  213.120.234.54

    Non-authoritative answer:
    Name:    whoami.akamai.net
    Address:  81.139.56.75


    C:\>

     

    0
    Comment actions Permalink
  • Avatar
    open16


    C:\>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : lenovo
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Mixed
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Ethernet:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Qualcomm Atheros AR8172/8176/8178 PCI-E Fast Ethernet Controller (NDIS 6.30)
       Physical Address. . . . . . . . . : 20-1A-06-A3-51-61
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Local Area Connection* 3:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
       Physical Address. . . . . . . . . : 74-DA-38-8B-EF-AA
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wi-Fi 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom 802.11n Network Adapter
       Physical Address. . . . . . . . . : 48-5A-B6-D5-C0-C7
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wi-Fi:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : 150Mbps Wireless 802.11bgn Nano USB Adapter
       Physical Address. . . . . . . . . : 74-DA-38-8B-EF-AA
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.22(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 01 December 2016 16:33:07
       Lease Expires . . . . . . . . . . : 02 December 2016 17:34:30
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 213.120.234.54
                                           213.120.234.30
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Ethernet 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : TAP-Windows Adapter V9
       Physical Address. . . . . . . . . : 00-FF-69-ED-48-16
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    C:\>

    0
    Comment actions Permalink
  • Avatar
    open16

    re:  Did you get a dynamic or a static IP address from your ISP?

    It's a Dynamic IP but I have DMZ so I can see a security camera

    0
    Comment actions Permalink
  • Avatar
    open16

    Thank you very much for helping

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    I see now, your router seems to propagate the WAN DNS server addresses assigned by your ISP via DHCP to the end user devices instead of to operate as DNS server and forwarder.  This is extremely bad firmware programming.  See if there's a newer firmware version available.

    Regardless, let's switch to plan B for the time being.  Configure the OpenDNS resolver addresses here now, on the DHCP/LAN side of the router:

    Then see if it works: http://welcome.opendns.com/

    Also, seeing from the first output, your IP address 86.131.211.150 is not registered with your dashboard network at https://dashboard.opendns.com/settings/
    If you want to use your dashboard settings, you must update it, e.g. manually at the dashboard.  If your Updater doesn't do it, then ensure that the option "Send Dns-O-Matic Updates" of the Updater is not checked.

    0
    Comment actions Permalink
  • Avatar
    open16

    Thank you very much for your support, I have updated firmware then made the config changes you suggested but lost all internet access

    Unfortunately, there are multiple users on this network and I have been 'strongly encouraged' to stop messing with the router so I have reverted to standard settings and will change the DNS on my own PC

    Thank you very much for your help, I very much appreciate your advice

    0
    Comment actions Permalink
  • Avatar
    open16

    Hey I worked it out

    step 1:

    step 2:

    Thanks for your help, hope this helps other users

    1
    Comment actions Permalink
  • Avatar
    rotblitz

    Great!  I have simply overseen the option "Force router to use..." in the user manual.

    Enjoy OpenDNS!

    0
    Comment actions Permalink
  • Avatar
    open16

    Thanks again, if you had not responded I would not have had the confidence to keep searching so thank you!

    0
    Comment actions Permalink
  • Avatar
    open16

    It is a very good router

    0
    Comment actions Permalink

Please sign in to leave a comment.