Chrome for Android not filtering

Comments

17 comments

  • Avatar
    rotblitz

    Visit http://welcome.opendns.com/ with Chrome of these Android devices to see if they're using OpenDNS at all.  If not, check the Android network settings to ensure that you are really connected with your router's WLAN, and that no other DNS resolvers are explicitly configured.

    Still problems?  Install the app from https://dyn.com/apps/dig/
    Then query debug.opendns.com and select TXT.  Take a screen shot and post it here.

    0
    Comment actions Permalink
  • Avatar
    shah89786

    I can confirm that when I do the test with chrome browser it says I am not using opendns but when I use a different browser on the same device it says I am protected so I am definately using OpenDNS but chrome seems to be bypassing it somehow (I have data saver disabled and have done a flush including uninstallation and reinstalling chrome) I am sure im using my home WiFi. And I have configured my router with opendns. The DYN app is not available on android play store and I also dont have working laptop to hand.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, it seems your Chrome browser circumvents your DNS settings and is using its own.  No idea, I don't have an Android device at hand and cannot reproduce it.  Let's see what others can say.

    Here's an old related thread: https://support.opendns.com/hc/en-us/community/posts/220028167

    Here's another app which can configure OpenDNS on Android:
    https://play.google.com/store/apps/details?id=uk.co.mytechie.setDNS
    You may try it to see if it helps.

    0
    Comment actions Permalink
  • Avatar
    shah89786

    That app is only for rooted phones which is not what I have. And that thread is over 2 years old and what it suggests is that "data saver enabled" causes bypass of opendns. In my situation this is not the case. I have data saver disabled. Can someone please help me rectify this. I am also considering to buy a nwtgear router but im worried chrome may still bypass.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Did you try this?  https://support.opendns.com/hc/en-us/articles/228009007

    0
    Comment actions Permalink
  • Avatar
    shah89786

    Yes that was one of the first things I tried but still no luck

    0
    Comment actions Permalink
  • Avatar
    shah89786

    How can it filter for my android tablet but not for the mobile device.

    0
    Comment actions Permalink
  • Avatar
    shah89786

    Seems as though many people have had this problem on chrome but there is no solution that I've found yet. I find it astonishing that opendns have not resolved this for customers. The only thing left for me to do is individually enter addresses into the router firewall block list.

    0
    Comment actions Permalink
  • Avatar
    mattwilson9090

    Why should OpenDNS resolve it when it is a Google product that is redirecting all DNS lookups, not just OpenDNS?

    Since it's very likely hardcoded into the app, what could OpenDNS do about it anyway?

    1
    Comment actions Permalink
  • Avatar
    rotblitz

    "I find it astonishing that opendns have not resolved this for customers."

    OpenDNS cannot repair your car or heal the world.  Chrome and Android have nothing to do with OpenDNS.  There is nothing to solve for OpenDNS.

    The deal is this: You are to send your DNS queries to OpenDNS, and OpenDNS is to respond according to your dashboard settings.  This is what is guaranteed.  If you even do not send your DNS traffic to OpenDNS, then OpenDNS has nothing to do with it and is out of scope.  You are free to send your DNS traffic to whatever DNS service, but you do not accuse OpenDNS for this.

    Saying that it is not you, but Chrome?  Well, feel free to not use it!  Or complain with the developers of Chrome for Android.  Here's the wrong place!

    If you want to see what DNS service your Chrome is using, you can find out by visiting those with your Chrome:
    https://www.dnsleaktest.com/
    https://ipleak.net/
    http://dnsleak.com/

    "How can it filter for my android tablet but not for the mobile device."

    Good question!  Ask Google or the Android/Chrome developers.  They know!  And this difference may be the right approach to find also a solution for your smart phone.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I think I found a solution: disable the Data Saver option.
    https://support.google.com/chrome/answer/2392284?co=GENIE.Platform%3DAndroid&hl=en

    2
    Comment actions Permalink
  • Avatar
    rmartin12345678910

    I was seeing my Chrome browser bypass Open DNS settings as well. I disabled the data saver extension, and everything's working right again.

    1
    Comment actions Permalink
  • Avatar
    lagonmanu

    Same for me, it was Chrome Data Saver Option...

    1
    Comment actions Permalink
  • Avatar
    dhus

    Switching "data saver" off in the phone Settings app is not enough, you also have to disable"Lite Mode" in Chrome's settings.

    1
    Comment actions Permalink
  • Avatar
    rotblitz

    This statement is wrong. Correct is that the Data Saver mode has changed its name to Lite Mode.

    -1
    Comment actions Permalink
  • Avatar
    dhus

    My previous statement is correct.  I have a phone with Android 9, there is a "data saver" option in the phone settings app (the one with the cog icon) , whether this is on or not makes no difference to the issue of filtering.  There is a separate "Lite Mode" option in Chrome.  If you open Chrome touch the three dots at the top and go to "Settings" there ia a section called "Advanced" with "Lite Mode" among other options, this must be turned off.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Interesting, you know it better than the Chromium developers.
    https://blog.chromium.org/2019/04/data-saver-is-now-lite-mode.html

    0
    Comment actions Permalink

Please sign in to leave a comment.