Constantly getting kicked off OpenDNS

Comments

26 comments

  • Avatar
    rotblitz

    Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show dns

     

    0
    Comment actions Permalink
  • Avatar
    prittman

    Thanks for the quick reply.

    Not sure if this is what you wanted---I just ran this from the command prompt, as administrator, from the prompt that it gave me (C/Win/System32):

    nslookup -type=txt debug.opendns.com. 208.67.220.220

    Server: resolver2.opendns.com

    Address: 208.67.220.220

     

    Non-authoritative answer:

    debug.opendns.com text =

     

    "server m27.lax"

    debug.opendns.com text =

     

    "flags 20 0 8050 3950000760000000000"

    debug.opendns.com text =

     

    "originid 8136251"

    debug.opendns.com text =

     

    "actype 2"

    debug.opendns.com text =

     

    "bundle 3065687"

    debug.opendns.com text =

     

    "source 71.95.239.136:32865"

     

    nslookup -type=txt which.opendns.com.

    C:\WINDOWS\system32>nslookup -type=txt which.opendns.com.
    Server:  rns01.charter.com
    Address:  2607:f428:ffff:ffff::1

    Non-authoritative answer:
    which.opendns.com       text =

            "I am not an OpenDNS resolver."

    nslookup whoami.akamai.net.
    Server:  rns01.charter.com
    Address:  2607:f428:ffff:ffff::1

    Non-authoritative answer:
    Name:    whoami.akamai.net
    Address:  68.114.44.3

    netsh interface ipv4 show dns
    Configuration for interface "Ethernet"
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only

    Configuration for interface "Local Area Connection* 2"
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only

    Configuration for interface "Wi-Fi"
        DNS servers configured through DHCP:  208.67.222.222
                                              208.67.220.220
                                              192.168.1.1
        Register with which suffix:           Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only


    Is this what you were looking for?



     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Yes, this is what I was looking for.

    You are not using OpenDNS, but your ISP's DNSv6 service:

    Server:  rns01.charter.com
    Address:  2607:f428:ffff:ffff::1

    If you have IPv6 connectivity, you must also configure the IPv6 settings on the router or on the computer from the following resolvers:
    ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde

    Another concern is this:

    Configuration for interface "Wi-Fi"
        DNS servers configured through DHCP:  208.67.222.222
                                              208.67.220.220
                                              192.168.1.1

    Your router should propagate only its own IP address 192.168.1.1. or the OpenDNS resolver addresses, not both.  Ensure that you filled all DNS server slots on the router (IPv4) with OpenDNS addresses:
    208.67.222.222   208.67.220.220   208.67.222.220   208.67.220.222

    0
    Comment actions Permalink
  • Avatar
    prittman

    Would would happen if I was to simply disable IPv6? Do I really need it?

     

    I inserted the last two DNS series (208.xxxxx)  in my router's browser interface.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Disabling IPv6 is another option.  But you cannot reach IPv6-only destinations anymore which may not be a problem for you.

    0
    Comment actions Permalink
  • Avatar
    prittman (Edited )

    Since it is the wave of teh future, I'd like to keep it enabled if I can, but I'm getting feedback from the forum for my router, that it might not be possible to configure those IPv6 resolvers (the numbers that start with fff that you gave me above.

     

    Here is a screenshot of the page where I can configure IPv6 on my linksys router:

    https://imgur.com/a/upVer

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You can post screen shots directly here.  (Image upload services may be blocked by OpenDNS settings...)

    See here:

    And yes, it doesn't look like you can configure DNSv6 resolver addresses, so you may disable IPv6 connectivity altogether.  Another option is to configure the addresses in the IPv6 network settings of your computer.  This does work.

    0
    Comment actions Permalink
  • Avatar
    prittman

    So I would do that, by going into my laptop (I'm connected wirelessly to the internet via my router) and going into the Edit IP Settings, and set that to manual, correct--with Windows 10?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Correct.

    0
    Comment actions Permalink
  • Avatar
    prittman

    Now its asking me for "subnet prefix length" and "gateway," in the IPv4 section. Any ideas on what I should type in?

     

    Actually, its doing this for both IPv4 and IPv6.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Do not change any IP addresses or such. Only change the DNS server addresses for IPv6.

    0
    Comment actions Permalink
  • Avatar
    prittman

    One more thing--I have this router set up to give a wired connection to a desktop computer (in addition to my wireless laptop)--so whatever I do with my laptop, I can't screw up the internet connection to my desktop (at this point, it doesn't matter to me if the desktop has OpenDNS--I just need the desktop to stay online).

    0
    Comment actions Permalink
  • Avatar
    prittman

    OK, so the only data I enter in my laptop is the fff numbers for IPv6, and the 208 numbers for IPv4?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    What you configure on the laptop has no impact on the desktop computer.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Only IPv6 DNS. IPv4 is covered by the router.

    0
    Comment actions Permalink
  • Avatar
    prittman

    Ugh! didn't work. I entered the first 2 fff numbers in the IPv6 section on my laptop, saved it, rebooted my router, and I am online, but still no OpenDNS.

     

    Thanks anyways.I think I'll open up a support ticket and if that doesn't work, I'll look elsewhere.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Flush your local caches on the PC. Then post the output of the diagnostic commands again.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    And note that the numbers start with two colons.

    0
    Comment actions Permalink
  • Avatar
    prittman

    DNS cache flushed. I don't need to reboot, do i?

     

    Here is the results:

    nslookup -type=txt debug.opendns.com. 208.67.220.220

    Server:  resolver2.opendns.com
    Address:  208.67.220.220

    Non-authoritative answer:
    debug.opendns.com       text =

            "server m47.lax"
    debug.opendns.com       text =

            "flags 20 0 8050 3950000760000000000"
    debug.opendns.com       text =

            "originid 8136251"
    debug.opendns.com       text =

            "actype 2"
    debug.opendns.com       text =

            "bundle 3065687"
    debug.opendns.com       text =

            "source 71.95.239.136:2227"

    nslookup -type=txt which.opendns.com.

    Server:  rns01.charter.com
    Address:  2607:f428:ffff:ffff::1

    Non-authoritative answer:
    which.opendns.com       text =

            "I am not an OpenDNS resolver."

     

    nslookup whoami.akamai.net.
    Server:  rns01.charter.com
    Address:  2607:f428:ffff:ffff::1

    Non-authoritative answer:
    Name:    whoami.akamai.net
    Address:  68.114.44.2

    netsh interface ipv4 show dns
    Configuration for interface "Ethernet"
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only

    Configuration for interface "Local Area Connection* 2"
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only

    Configuration for interface "Wi-Fi"
        DNS servers configured through DHCP:  208.67.222.222
                                              208.67.220.220
                                              208.67.222.220
        Register with which suffix:           Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
     
    0
    Comment actions Permalink
  • Avatar
    prittman

    Hmm well the system tray updater utility says I"m using OpenDNS now....

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You are still using Charter's DNSv6 service, as if you hadn't configured IPv6 DNS on your laptop.  Post the output of this command now:

    netsh interface ipv6 show dns

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    This is what you should have configured on your laptop:

    0
    Comment actions Permalink
  • Avatar
    prittman

    Here is the results of this most recent command:

    Configuration for interface "Ethernet"
        DNS servers configured through DHCP:  fec0:0:0:ffff::1%1
                                              fec0:0:0:ffff::2%1
                                              fec0:0:0:ffff::3%1
        Register with which suffix:           Primary only

    Configuration for interface "Local Area Connection* 2"
        DNS servers configured through DHCP:  fec0:0:0:ffff::1%1
                                              fec0:0:0:ffff::2%1
                                              fec0:0:0:ffff::3%1
        Register with which suffix:           Primary only

    Configuration for interface "Wi-Fi"
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
        Statically Configured DNS Servers:    fec0:0:0:ffff::1%1
                                              fec0:0:0:ffff::2%1
                                              fec0:0:0:ffff::3%1
        Register with which suffix:           Primary only

    Configuration for interface "Teredo Tunneling Pseudo-Interface"
        Statically Configured DNS Servers:    None
        Register with which suffix:           None

    0
    Comment actions Permalink
  • Avatar
    prittman

    I just went in and changed the settings you showed me in your TCP/IPv6 screenshot. I ran that one command again. Here are the results:


    Configuration for interface "Ethernet"
        DNS servers configured through DHCP:  fec0:0:0:ffff::1%1
                                              fec0:0:0:ffff::2%1
                                              fec0:0:0:ffff::3%1
        Register with which suffix:           Primary only

    Configuration for interface "Local Area Connection* 2"
        DNS servers configured through DHCP:  fec0:0:0:ffff::1%1
                                              fec0:0:0:ffff::2%1
                                              fec0:0:0:ffff::3%1
        Register with which suffix:           Primary only

    Configuration for interface "Wi-Fi"
        Statically Configured DNS Servers:    ::ffff:208.67.222.222
                                              ::ffff:208.67.220.220
        Register with which suffix:           Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
        Statically Configured DNS Servers:    fec0:0:0:ffff::1%1
                                              fec0:0:0:ffff::2%1
                                              fec0:0:0:ffff::3%1
        Register with which suffix:           Primary only

    Configuration for interface "Teredo Tunneling Pseudo-Interface"
        Statically Configured DNS Servers:    None
        Register with which suffix:           None

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, as I suspected, you didn't configure your laptop correctly for IPv6 DNS.  Now, according to the last command output, it looks like it should look.  Let me know if you still face any problems.

    0
    Comment actions Permalink
  • Avatar
    prittman

    Thanks a lot for all your time! I do appreciate it.

    0
    Comment actions Permalink

Please sign in to leave a comment.