Help with Netgear and changing DNS with parental controls enabled.

Comments

12 comments

  • Avatar
    rotblitz

    "I'm trying to get a device online that seems to have problems working with OpenDNS parental controls."

    What is the exact problem?

    "What do I have to do to change my own router DNS settings now?"

    Well, doesn't the message say it really clearly?  "If you need to configure DNS manually, please disable the Parental Controls".  You don't question this, just do it!

    Also, I think your approach of temporary settings changes is at least suboptimal.  What about the following?

    • Disable Live Parental Controls.  (Now you become able to change the DNS settings of the router.)
    • Use OpenDNS Home instead of LPC, i.e. configure the router with the OpenDNS resolver addresses.  Your dashboard is now at https://dashboard.opendns.com/settings/ and you want to run an Updater within your network.
    • Configure the mentioned device with a different (non-OpenDNS) DNS service.

    You're done then!

  • Avatar
    nattybohman

    Hello and thanks for getting back to me.

    Unfortunately, I must've been very unclear when I said  "Then it opens a web page for Live Parental Controls with no place to disable parental controls on the page anywhere!! "

    If I could disable parental controls through the page it takes me to, I would've done it instead of playing with it for 45 minutes and typing up this question. Believe me!

    The only thing the page lets me do is to unblock all of the websites. I don't want to do that. I just want to be able to configure my DNS servers. However I need to know how to turn off the parental controls.

    The exact problem is too much to go into (involving a raspberry pi and the DreamPi OS). It's enough to know that it's not working, but works on all other wifi networks that I've tried it on. The only difference being OpenDNS on my network.

    I agree with your statement that turning it on and off is suboptimal. However, I don't understand your directions here.

    "Use OpenDNS Home instead of LPC, i.e. configure the router with the OpenDNS resolver addresses.  Your dashboard is now at https://dashboard.opendns.com/settings/ and you want to run an Updater within your network."

    I run an updater already to update my dynamic IP. However, I don't understand the rest of your instructions for the second step. I already have the router configured with OpenDNS server addresses. That's what I want to be able to change.

    Assuming I can figure out how to Disable Live Parental controls, I'd love to do steps 2 and 3 because they seem like they'd solve my problem completely.

    If you could tell me exactly how to disable Parental Controls so that I can change the DNS setting in my router config, I'd be very grateful.

    If you can explain in a more detailed way how to just exclude my Raspberry Pi from using OpenDNS, that would be icing on the cake.

     

    Thank you, in advance, for your help.

     

     

  • Avatar
    rotblitz

    "However I need to know how to turn off the parental controls."

    No problem, see https://support.opendns.com/hc/en-us/articles/227987607

    "However, I don't understand your directions here."

    Netgear LPC and OpenDNS Home are incompatible services, as you have seen.  You can use either the one or the other.  I explained how to use OpenDNS Home after disabling and instead of LPC.
    See also https://support.opendns.com/hc/en-us/articles/228006447

    "I run an updater already to update my dynamic IP."

    This was wrong.  You must not run an Updater with LPC enabled.

    "If you can explain in a more detailed way how to just exclude my Raspberry Pi from using OpenDNS, that would be icing on the cake."

    No, I can't, because I don't have a Raspberry Pi.  But I'm sure this is described often, how to configure a DNS service on that device.  An internet search should be able to help here.

  • Avatar
    nattybohman

    Thanks again for getting back to me rotblitz. I really do appreciate your help. It's just a little frustrating because it seems like we're having trouble communicating.

    I'll try to keep everything short and sweet so there's not a lot to read.

    This part is very important.

    1. I CANNOT turn of the parental controls. When I click the button that says Parental Controls in Netgear like it says in your link. It doesn't take me to the screen shown. Instead it opens another webpage that I need to login to called NetGear Live Parental Controls. This page looks nothing like the one in the link and there is NO PLACE TO DISABLE THE CONTROLS. There's only a Filtering level that I can change from High to None. I am attaching a picture of this screen.


    2. I used OpenDNS before getting my Netgear R6700 . When I got the router, I decided to use it's parental controls and that's why I was already running the updater when I got the router. If this is causing my inability to change DNS settings, then I can uninstall the updater program.

    3. I know that I can change the DNS settings on the PI itself, it would just be nice if there was a Netgear feature to exclude certain devices from the parental controls. I could've sworn there was. This would be a lot easier. That's why it would be icing on the cake, but not necessary.

    Please be clear that the main thing I want to do is #1. If I can get that done I'll be very happy. If I can exclude devices from the OpenDNS blocking using the GUI, that would be great, but not that important. 

    Looks like I've failed miserably at keeping it short. Hopefully you don't mind taking the time to read the whole thing.

    I appreciate your help.

    Thanks again.

     

  • Avatar
    lucasbishop (Edited )

    I have the same exact issue with a Netgear R6400v2, running the latest firmware.

    When I click "Parental Controls" inside the advanced settings of the web-based Netgear Genie, I get redirected to the "Default Settings" page for my device here:https://netgear.opendns.com

    Unfortunately not a single page there gives me the option to "disable" parent control.

    I tried installing the desktop Genie app for Mac OS. When try to manage Parental Control settings there, the login attempt fails with the message:

    "There was an error signing in, please make sure you're connected to the Internet and try again" -- even though I am connected to the Internet and my user/pass are accurate. I can in fact login to OpenDNS through a browser without issue. If I put an "incorrect" username in, the app says "we don't recognize that username," so it's obvious a lookup through the Internet is happening.

    Next, I even tried managing the parental controls from the iOS app as a workaround and the "enable/disable" switch refuses to acknowledge my requests to disable. I flip it to "disable"... after a second, it auto-flips back to "enable."

    I went to a link a previous commentor provided:

    https://dashboard.opendns.com/settings/

    ..at least there, I have more 'administrative' feeling features. I deleted all of my networks there.

    That didn't help.

    I deleted my account.

    That didn't help.

    No matter, what, Parental Controls remain enabled on my router. Even with my OpenDNS account deleted.

    I'm just going to factory reset my modem and NEVER install OpenDNS on a Netgear router ever again.

  • Avatar
    rotblitz

    I'm afraid I cannot help here, because I have neither a Netgear router nor a Raspberry Pi.  Your best bet is to open a support ticket, "Submit a request" above.

    Just this, https://dashboard.opendns.com/settings/ cannot be used with LPC, just with OpenDNS Home.  These two services are incompatible, and you can use either the one or the other.

  • Avatar
    aegix

    Exact same issue here - once enabled, there is no place to actually DISABLE parental controls.  

    rotblitz - for the record, this has absolutely nothing to do with a Raspberry Pi or LPC vs OpenDNS Home that I'm aware of.  We have NightHawk routers that redirect us to OpenDNS once parental controls are enabled, but no mechanism to disable this.  As a result of this being enabled, we are unable to modify our DNS configuration for our routers.

  • Avatar
    rotblitz

    @aegix

    I say it again, open a support ticket, "Submit a request" above.  Or even better, raise this with Netgear support.  The router firmware and Genie app are not OpenDNS', but Netgear's.

  • Avatar
    aegix

    I think the answer we're looking for is:  No, there is no way to disable Parental Controls from the OpenDNS site.  This must be done via the router / app.

    I was able to resolve by factory default'ing my router last night and re-configuring w/o parental controls.  This just bypasses the DNS configuration pointing to OpenDNS.

  • Avatar
    nattybohman (Edited )

    I regretted mentioning the Raspberry Pi the moment I hit post. I knew it had nothing to do with the actual problem and would lead anyone trying to help me down a bad rabbit hole.

    I've been thinking the same thing about factory resetting the router. It's crazy that there's no way to turn off parental controls once you turn them on. There are so many little things I've set up on my network over the years, that I dread finding out what will break. I wish I'd taken better notes I'll make sure all go through all of the config pages before hitting reset. ;-).

    I actually thought about a netgear support ticket, but FYI they won't let you submit one after the first 90 days.

    Thanks for all of your help guys. Looks like I've got more work ahead for my next day off, but I feel better knowing I'm not crazy.

     

  • Avatar
    aegix

    @nattybohman - you can backup your config to a file, though I don't know of any way to selectively restore / edit the file to remove the "Parental Controls" configuration - so unsure how much help that will be.

Please sign in to leave a comment.