Unable to connect - Comcast/Xfinity w/ Netgear 3700 Router

Comments

5 comments

  • Avatar
    rotblitz (Edited )

    Open a command prompt window, and copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup myip.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

     

  • Avatar
    prff651

    Microsoft Windows [Version 10.0.16299.431]
    (c) 2017 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server:  resolver2.opendns.com
    Address:  208.67.220.220

    Non-authoritative answer:
    debug.opendns.com       text =

            "server m45.mia"
    debug.opendns.com       text =

            "flags 20 0 70 180000000000000000007950800000000000000"
    debug.opendns.com       text =

            "originid 0"
    debug.opendns.com       text =

            "actype 0"
    debug.opendns.com       text =

            "source 73.138.92.200:61787"

    C:\WINDOWS\system32>nslookup -type=txt which.opendns.com.
    Server:  cdns01.comcast.net
    Address:  2001:558:feed::1

    Non-authoritative answer:
    which.opendns.com       text =

            "I am not an OpenDNS resolver."

    C:\WINDOWS\system32>nslookup myip.opendns.com.
    Server:  cdns01.comcast.net
    Address:  2001:558:feed::1

    *** cdns01.comcast.net can't find myip.opendns.com.: Non-existent domain

    C:\WINDOWS\system32>nslookup whoami.akamai.net.
    Server:  cdns01.comcast.net
    Address:  2001:558:feed::1

    Non-authoritative answer:
    Name:    whoami.akamai.net
    Address:  69.252.41.203


    C:\WINDOWS\system32>netsh interface ipv4 show config

    Configuration for interface "Ethernet"
        DHCP enabled:                         Yes
        InterfaceMetric:                      5
        DNS servers configured through DHCP:  192.168.0.1
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 14"
        DHCP enabled:                         Yes
        InterfaceMetric:                      25
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
        DHCP enabled:                         Yes
        IP Address:                           192.168.0.11
        Subnet Prefix:                        192.168.0.0/24 (mask 255.255.255.0)
        Default Gateway:                      192.168.0.1
        Gateway Metric:                       0
        InterfaceMetric:                      55
        Statically Configured DNS Servers:    208.67.222.222
                                              208.67.220.220
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
        DHCP enabled:                         No
        IP Address:                           127.0.0.1
        Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
        InterfaceMetric:                      75
        Statically Configured DNS Servers:    None
        Register with which suffix:           None
        Statically Configured WINS Servers:   None


    C:\WINDOWS\system32>]
    ']' is not recognized as an internal or external command,
    operable program or batch file.

    C:\WINDOWS\system32>

     

     

  • Avatar
    rotblitz (Edited )

    You have two problems.

    1. You are not using OpenDNS, but Comcast's DNSv6 service:
      Server:  cdns01.comcast.net
      Address:  2001:558:feed::1
      Configure your router or your computer also with the following DNS addresses in your IPv6 settings
      ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde

    2. If you have fixed problem number 1, you will be facing problem number 2:
      Your IP address 73.138.92.200 is not registered at https://dashboard.opendns.com/settings/ so that your dashboard settings will not take effect, but you will be using the OpenDNS defaults.  Ensure that your IP address is registered there.
  • Avatar
    prff651

    Thanks so much for your help so far, rotblitz!

    I was able to configure the computer with the DNS addresses above and I now get the green checkmark and the InternetBadGuys site is now blocked.  Success!

    Now on to your item # 2 above... I've gone to the dashboard, Deployments -> Core Identities -> Networks, entered my network name and IP address and it simply says "Inactive" and nothing shows up on my dashboard.  Doesn't matter whether the Dynamic IP box is checked or not.  After doing a search I reset my router/cable modem to try and get a different IP address, but that doesn't happen. 

    Any ideas, please?

  • Avatar
    rotblitz (Edited )

    According to "Deployments -> Core Identities -> Networks" you are using the Umbrella dashboard at https://dashboard.umbrella.com/ because you have subscribed to Umbrella or to PremiumDNS, not the OpenDNS Home dashboard as assumed by me above.  Run an update client or perform a manual update to register your IP address with your dashboard network.  Ensure before that the network is set to "Dynamic" at the dashboard.

    Manual update URL:

    https://updates.opendns.com/nic/update?hostname=networkname

     "I reset my router/cable modem to try and get a different IP address"

    You most likely do not need another IP address, because your IP address was not registered at all with OpenDNS or Umbrella when you posted the command outputs.  And this is why your network shows "inactive", because no DNS traffic could be logged against your dashboard network.  The system can recognize your DNS traffic only where it knows your IP address.

Please sign in to leave a comment.