DNS Server not working

Comments

9 comments

  • Avatar
    rotblitz (Edited )

    Open a command prompt window on your computer, and copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config
    netsh interface ipv6 show dns

    Also, what exact router model do you have?  Can you post a screen shot of where you have configured the OpenDNS addresses?

  • Avatar
    cuse165

    I will try that. I don't get a error or can't really take a screen shot. I can just tell it's not using the DNS Servers just by browsing the Internet. The DNS Servers are not doing what they say they do. That's how I can just tell. I read on some networking websites that it is technically possible for ISPS to override user's DNS with a default one, and some service providers are doing this. Has anyone heard of this could it be true?

  • Avatar
    rotblitz

    This is true.  But I can only say what your problem is if I see the command outputs.  Else I even cannot guess.

  • Avatar
    cuse165

    Pictures and Info:https://1drv.ms/f/s!AtxxebpM5QtOgr1mFfMv4dnC49d1qw

    Its a NETGEAR Modem and Router in one C6300

  • Avatar
    rotblitz (Edited )

    Why didn't you post this stuff here instead of uploading it to OneDrive?  Whatever,...

    As I can see, you're not using OpenDNS, but your ISP's DNSv6 service:

    Server: UnKnown
    Address: 2001:1998:f00:1::1

    Clearly not an OpenDNS resolver address!  Same as IPv4, you must configure also the IPv6 side on the router or on the computer with addresses from the following list:
    ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde

    And you forgot to post the output of the last command.


    Another problem is this:

    You have configured a non-OpenDNS address 198.101.242.72 as 3rd DNS server address.  Replace this by an OpenDNS address: 208.67.222.220 or 208.67.220.222.

    After having applied these two fixes, everything should work fine.  It has nothing to do with your ISP or your router; it was just wrong or missing configuration.

  • Avatar
    jonathan

    Hi rotblitz, I'm having a similar problem. I've been connected to opendns for a couple of years now and not made any changes but recently have noticed sites not being filtered. the Welcome to OpenDNS test page shows I am not connected, but my router's DNS settings are as above - 208.67.222.222 & ...220.220. I have a DrayTek Vigor 2860, screenshot here:


    Any ideas where it's going wrong?

  • Avatar
    rotblitz

    @jonathan, can you please open an own thread instead of hi-jacking this one?  And I need to see the command outputs.

  • Avatar
    cuse165

    Thank you for your answer I will mark it as answered. In my router you can not change the DNS for IPv6.

  • Avatar
    rotblitz

    Then you may have the option to disable IPv6 connectivity.  Or configure the addresses above on the end user devices.

Please sign in to leave a comment.