OpenDNS IP in network adapter is not working in Windows 10

Comments

6 comments

  • Avatar
    rotblitz

    In case you have dual-stack (IPv4 and IPv6) connectivity, configure addresses from the following list in the IPv6 properties of the active network connection:
    ::ffff:d043:dede   ::ffff:d043:dcdc   ::ffff:d043:dedc   ::ffff:d043:dcde

    If it is not IPv6, copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config (Windows only)
    netsh interface ipv6 show dns (Windows only)

     

    0
    Comment actions Permalink
  • Avatar
    ineuw (Edited )

    Much thanks for your reply. I do not use ipv6 at all. Here is the requested info.

    Microsoft Windows [Version 10.0.17134.191]
    (c) 2018 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server:  resolver2.opendns.com
    Address:  208.67.220.220

    Non-authoritative answer:
    debug.opendns.com       text =

            "server m37.nyc"
    debug.opendns.com       text =

            "flags 20 0 70 180000000000000000007950800000000000000"
    debug.opendns.com       text =

            "originid 0"
    debug.opendns.com       text =

            "actype 0"
    debug.opendns.com       text =

            "source 66.36.141.245:60153"

    C:\Windows\system32>nslookup -type=txt which.opendns.com
    Server:  dsldevice.lan
    Address:  fe80::e2b9:e5ff:fe22:5ba

    Non-authoritative answer:
    which.opendns.com       text =

            "I am not an OpenDNS resolver."

    C:\Windows\system32>netsh interface ipv4 show config

    Configuration for interface "Ethernet 2"
        DHCP enabled:                         Yes
        IP Address:                           192.168.1.84
        Subnet Prefix:                        192.168.1.0/24 (mask 255.255.255.0)
        Default Gateway:                      192.168.1.254
        Gateway Metric:                       0
        InterfaceMetric:                      35
        Statically Configured DNS Servers:    208.67.222.222
                                              208.67.220.220
        Register with which suffix:           Both primary and connection-specific
        WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
        DHCP enabled:                         No
        IP Address:                           127.0.0.1
        Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
        InterfaceMetric:                      75
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None


    C:\Windows\system32>netsh interface ipv6 show dns

    Configuration for interface "Ethernet 2"
        DNS servers configured through DHCP:  fe80::e2b9:e5ff:fe22:5ba%6
        Register with which suffix:           Both primary and connection-specific

    Configuration for interface "Loopback Pseudo-Interface 1"
        Statically Configured DNS Servers:    fec0:0:0:ffff::1%1
                                              fec0:0:0:ffff::2%1
                                              fec0:0:0:ffff::3%1
        Register with which suffix:           Primary only

    0
    Comment actions Permalink
  • Avatar
    ineuw

    I am using Avast the free version, and I don't think that it's hijacking the DNS.

    C:\Windows\system32>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : WIN10P64B
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : 208.67.222.222
                                           208.67.220.220

    Ethernet adapter Ethernet 2:

       Connection-specific DNS Suffix  . : lan
       Description . . . . . . . . . . . : Intel(R) Ethernet Connection (7) I219-V #2
       Physical Address. . . . . . . . . : 70-85-C2-7B-78-7D
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::846d:4bac:9606:6bd%6(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.84(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : September 5, 2018 18:24:03
       Lease Expires . . . . . . . . . . : September 6, 2018 18:24:03
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DHCPv6 IAID . . . . . . . . . . . : 712017346
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-22-BB-B2-78-E0-D5-5E-89-D8-13
       DNS Servers . . . . . . . . . . . : fe80::e2b9:e5ff:fe22:5ba%6
                                           208.67.222.222
                                           208.67.220.220
       NetBIOS over Tcpip. . . . . . . . : Enabled

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You are clearly not using OpenDNS, but this link-local IPv6 address of your router:

    Server:  dsldevice.lan
    Address:  fe80::e2b9:e5ff:fe22:5ba

    As you don't have IPv6 connectivity, you disable IPv6 in the active network adapter on the computer, i.e. uncheck the checkbox for IPv6.

    A second different problem is that you didn't register your public IPv4 address 66.36.141.245 at https://dashboard.opendns.com/settings/ at least at the time when you executed the commands.
    Don't forget to run an Updater to keep your IP address information updated at OpenDNS.

    Regarding Avast hijacking your DNS traffic, I cannot comment, because you forgot to post the command output of 'nslookup whoami.akamai.net.'.

    0
    Comment actions Permalink
  • Avatar
    ineuw

    Thanks for all your help and apologize omitting the 'nslookup whoami.akamai.net' report (below), by which I assume that nothing is hijacked. Corrected everything you pointed out, updated my account and installed the updater as well, and now everything is working fine with Open DNS. Thanks again

    C:\Windows\system32>nslookup whoami.akamai.net
    Server:  resolver1.opendns.com
    Address:  208.67.222.222

    Name:    whoami.akamai.net
    Address:  2620:0:cc9::71

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Good to hear!

    And no, Avast does not redirect your DNS traffic.  This 2620:0:cc9::71 is an OpenDNS IPv6 address.

    nslookup 2620:0:cc9::71
    Server:  local
    Address:  10.165.123.54

    Name:    m49.nyc.opendns.com
    Address:  2620:0:cc9::71

     

    0
    Comment actions Permalink

Please sign in to leave a comment.