OpenDNS Working Only Sometimes

Comments

9 comments

  • Avatar
    rotblitz

    It was working fine when you executed the command.  I cannot see a problem.

    Ensure that you fill all three DNS fields with OpenDNS resolver addresses from this list:
    208.67.222.222   208.67.220.220   208.67.222.220   208.67.220.222

    0
    Comment actions Permalink
  • Avatar
    lisabarbero

    Yes all three of them are filled in. I'm pretty sure this is the bug with Linksys routers - that Linksys is apparently already aware of and doesn't care about. When checking router diagnostic reports, the DNS servers are never set to OpenDNS. No matter that I've changed them in the settings and that they work occassionally, they are never set to OpenDNS nameservers in the diagnostic reports. I've set my firmware back three times with no luck.

    We need our network protected for the kids so (unless someone has another answer) it's either get another new router or hope I can find a parental control solution through my ISP. There is a parental control option on the router itself but it's only able to block individual sites per device and not categories. Which means it's basically useless. Ugh. Linksys may be getting a complaint from me. Hopefully they'll decide to do something about this bug if more people speak up.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    It looks like you understand most of the options you have with this issue.

    • Raise this with Linksys to provide you with a firmware version allowing to consistently use a 3rd party DNS service like OpenDNS.
      See also https://support.opendns.com/hc/en-us/articles/228008007
    • Get another router.  (Unfortunately it doesn't look like that there is alternative firmware available like DD-WRT, Tomato, OpenWRT, etc. for this specific Linksys router model.  Else this would have been a viable option.)
    • Use an own internal DNS (and maybe DHCP) server which address is propagated through DHCP and which forwards your DNS traffic to OpenDNS.  (This is normally what a router should do.)
    • Else you still could configure OpenDNS on all related end user devices.

    "When checking router diagnostic reports, the DNS servers are never set to OpenDNS."

    This is not really the problem, because you cannot configure DNS server addresses on the WAN side on this router, but on the LAN/DHCP side only.  So for the WAN side the OpenDNS resolver addresses cannot show up.

    If the OpenDNS server addresses are also not displayed for the LAN side, then https://support.opendns.com/hc/en-us/articles/228008007 applies again.

    0
    Comment actions Permalink
  • Avatar
    lisabarbero

    Thank you for taking the time to address this. I set the firmware back again and it seems to be working so far today. We'll see if it drops off again. Thanks again. Much appreciated. :)

    0
    Comment actions Permalink
  • Avatar
    lisabarbero

    Okay, it's gone down again. Well sort of. The welcome page says I'm using OpenDNS and it blocks the internetbadguys link just fine. However, it's not blocking porn at all. I'm confused as to how it worked for a few days then just stopped again. I'm using the updater app as well. Any thoughts?

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Sure, all thoughts!

    The symptoms indicate that your IP address changed, but it was not updated at https://dashboard.opendns.com/settings/
    This causes that your dashboard settings don't take effect, but you're using the OpenDNS default settings.  It seems your Updater didn't do its job when the IP address changed.  Or you inherited an IP address which is still registered by another OpenDNS user, so the Updater was unable to register it for your dashboard.

    0
    Comment actions Permalink
  • Avatar
    lisabarbero

    Okay, thanks for that info. My IP matches with what's on my dashboard right now and I'm still experiencing some issues. After your comment, I've decided to switch to Family Shield since the default settings for that service seem to be more in line with what I need. So far, nothing has changed though it's been about an hour and I've reset my router and flushed the dns multiple times. I've also shut down the firewall on my router as an experiment as I suspect it's causing a lot of unnecessary SSL errors. Firefox and IE are both blocking the OpenDNS forums right now due to supposed expired certificates. Which doesn't sound right and makes me wonder if these two issues are related. Anyway, here's hoping it takes effect at some point today.  

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Ok, if you're still facing problems, tell them here with deep details, e.g. the domains not being blocked, not just "some issues".

    "it's causing a lot of unnecessary SSL errors. Firefox and IE are both blocking the OpenDNS forums right now due to supposed expired certificates."

    This indicates a different issue, unrelated to OpenDNS.  It looks as if your root CA certificate store is corrupt or something like that.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I need to correct me regarding "Firefox and IE are both blocking the OpenDNS forums right now due to supposed expired certificates".

    Just detected by chance that there were indeed problems with expired certificates: https://status.umbrella.com/#/detail/13
    But this should be resolved in the meantime.

    Are you still facing problems?

    0
    Comment actions Permalink

Please sign in to leave a comment.