Updater says no IP but router runs with OpenDNS DNS

Comments

4 comments

  • Avatar
    rotblitz

    I need more information.  Copy & paste the complete plain text output of the following diagnostic commands to here:
    (Just in case you don't know: you execute the commands in the Windows Command Prompt window or in the Mac OSX terminal window.)

    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config (Windows only)
    netsh interface ipv6 show dns (Windows only)
    ifconfig -a (Mac OSX only)

     

  • Avatar
    uccia

    Hi, thanks, here it is:

     

    nslookup -type=txt debug.opendns.com.

    Server: 8.8.8.8

    Address: 8.8.8.8#53

     

    nslookup whoami.akamai.net.

    Server: 8.8.8.8

    Address: 8.8.8.8#53

     

    Non-authoritative answer:

    Name: whoami.akamai.net

    Address: 74.125.40.76

     

    ifconfig -a

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384

    options=1203<RXCSUM,TXCSUM,TXSTATUS,SW_TIMESTAMP>

    inet 127.0.0.1 netmask 0xff000000

    inet6 ::1 prefixlen 128

    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1

    nd6 options=201<PERFORMNUD,DAD>

    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280

    stf0: flags=0<> mtu 1280

    XHC20: flags=0<> mtu 0

    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

    ether a0:99:9b:03:3b:3f

    inet6 fe80::807:4a95:6c92:9feb%en0 prefixlen 64 secured scopeid 0x5

    inet 10.0.1.2 netmask 0xffffff00 broadcast 10.0.1.255

    inet6 2601:19b:780:e2dd:18ac:a13b:1167:fb9c prefixlen 64 autoconf secured

    inet6 2601:19b:780:e2dd:5977:cc51:8066:b132 prefixlen 64 autoconf temporary

    nd6 options=201<PERFORMNUD,DAD>

    media: autoselect

    status: active

    p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304

    ether 02:99:9b:03:3b:3f

    media: autoselect

    status: inactive

    awdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1484

    ether 6a:97:e0:e2:79:f4

    inet6 fe80::6897:e0ff:fee2:79f4%awdl0 prefixlen 64 scopeid 0x7

    nd6 options=201<PERFORMNUD,DAD>

    media: autoselect

    status: active

    en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500

    options=60<TSO4,TSO6>

    ether 6a:00:00:5e:c7:c0

    media: autoselect <full-duplex>

    status: inactive

    en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500

    options=60<TSO4,TSO6>

    ether 6a:00:00:5e:c7:c1

    media: autoselect <full-duplex>

    status: inactive

    bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

    options=63<RXCSUM,TXCSUM,TSO4,TSO6>

    ether 6a:00:00:5e:c7:c0

    Configuration:

    id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0

    maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200

    root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0

    ipfilter disabled flags 0x2

    member: en1 flags=3<LEARNING,DISCOVER>

            ifmaxaddr 0 port 8 priority 0 path cost 0

    member: en2 flags=3<LEARNING,DISCOVER>

            ifmaxaddr 0 port 9 priority 0 path cost 0

    nd6 options=201<PERFORMNUD,DAD>

    media: <unknown type>

    status: inactive

    utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 2000

    inet6 fe80::7254:a23f:395a:7ca7%utun0 prefixlen 64 scopeid 0xb

    nd6 options=201<PERFORMNUD,DAD>

     

  • Avatar
    rotblitz (Edited )

    Well you intendedly overwrite your router settings with the DNS settings on your computer which is clearly Google Public DNS:

    Server: 8.8.8.8
    Address: 8.8.8.8#53

    No chance to ever use OpenDNS then...

    You must configure your computer's DNS settings to be obtained automatically via DHCP from the router, or you configure your router's IPv4 address as the only one DNS server address on the computer.

    You also seem to have IPv6 connectivity, so you should use DNSv6 addresses from the following list too:
    ::ffff:d043:dedc    ::ffff:d043:dcde    ::ffff:d043:dede    ::ffff:d043:dcdc

  • Avatar
    uccia

    Thank you so much! It works now!!!!

Please sign in to leave a comment.