Security config and content filtering is not working. DNS resolver is. Did all the settings. Suggestions? Windows 10, TP-Link Router, Google Chrome, Comcast ISP.

Comments

5 comments

  • Avatar
    rotblitz (Edited )

    Check if your IP address is registered at https://dashboard.opendns.com/settings/

    Ensure that the Data Saver extension is disabled in Chrome.  And flush your two local caches once: https://support.opendns.com/hc/en-us/articles/227988627
    And ensure that you have configured IPv6 in case of IPv6 connectivity from the following list of DNS server addresses:  ::ffff:d043:dedc   ::ffff:d043:dcde   ::ffff:d043:dede   ::ffff:d043:dcdc

    Still problems?  I need more information.  Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config
    netsh interface ipv6 show dns

     

  • Avatar
    sbarr12
    Microsoft Windows [Version 10.0.17134.407]
    (c) 2018 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    *** resolver1.opendns.com can't find debug.opendns.com.: Non-existent domain

    C:\WINDOWS\system32>nslookup whoami.akamai.net.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    Name: whoami.akamai.net
    Addresses: 2620:0:ccb::80
    207.244.98.94


    C:\WINDOWS\system32>netsh interface ipv4 show config

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.0.107
    Subnet Prefix: 192.168.0.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.0.1
    Gateway Metric: 0
    InterfaceMetric: 25
    Statically Configured DNS Servers: 208.67.222.222
    208.67.220.220
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None


    C:\WINDOWS\system32>netsh interface ipv6 show dns

    Configuration for interface "Loopback Pseudo-Interface 1"
    Statically Configured DNS Servers: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only


    C:\WINDOWS\system32>
  • Avatar
    rotblitz (Edited )

    It looks like something (maybe your ISP, involving Leaseweb USA, Inc.) intercepts your DNS traffic and redirects it to somewhere else.

    You may be able to circumvent this by using DNSCrypt (https://dnscrypt.info/).  Or call your ISP to opt out from this DNS redirection.

    See also https://support.opendns.com/hc/en-us/community/posts/115019065723

  • Avatar
    sbarr12

    Thanks, I tired this. I bypassed my TP-LINK AC1750 Router and went straight to my modem and it worked. Thoughts?

     

  • Avatar
    rotblitz

    Not really thoughts.  You configured OpenDNS on your computer:

     Statically Configured DNS Servers: 208.67.222.222
    208.67.220.220

    This usually overrides DNS configuration on the router or modem.  It may be that your TP-Link router did something with DNS traffic passing through, something like Comcast's Constant Guard or the Xfinity xFi app, both mentioned in the other thread I linked to.  I do not have Comcast, Xfinity or any of the mentioned devices, so it's pretty hard to try it out and find it out here myself.

Please sign in to leave a comment.