Wireless Devices Not Filtering

Comments

7 comments

  • Avatar
    rotblitz

    Do you have dual-stack connectivity (IPv4 and IPv6)?  In this case you must also configure the IPv6 side from the following list of addresses:  ::ffff:d043:dedc   ::ffff:d043:dcde   ::ffff:d043:dede   ::ffff:d043:dcdc

    If it is not this, copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You apparently do not have IPv6 connectivity, so you do not need to care about DNSv6.  Post the command outputs instead from a computer where it does not work, so that I may see what the problem is.

    0
    Comment actions Permalink
  • Avatar
    rjpack

    Sorry...I just read your message to post the results from a pc where this does not work.  Let me get those results.  The results I just posted are from my PC that does work...but that one is not wireless...it's a wired connection.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Good that you posted commands from the two computers.  The situation is totally different.

    Your Windows PC attempts to use the following DNS service:

    Server: UnKnown
    Address: 2601:681:4c00:3d77:22c9:d0ff:fe12:e36d

    This is clearly not an OpenDNS address, but some strange IPv6 address.  And as you don't have IPv6 connectivity, you don't get any response from it:

    *** UnKnown can't find ....: No response from server

    You have manually configured OpenDNS on the IPv4 side on the PC in the Ethernet interface, so your router's DNS settings are overwritten and ignored:

    Statically Configured DNS Servers: 208.67.222.222
                                                          208.67.220.220

    If your router would function properly, my suggestion would be to change the IPv4 network settings on the PC to be obtained automatically via DHCP from the router, but see below.  Also, uncheck the check box beside the IPv6 protocol to prevent from using non-reachable IPv6 resolvers as currently is the case, so that your PC can use the DNS servers configured for IPv4.

     

    On your Mac the situation is different.  You are using this DNS address which is your router and in principle fine:

    Server:  192.168.103.1
    Address: 192.168.103.1#53

    But your router does not forward your DNS queries to OpenDNS or any other DNS service, so you get:

    *** Can't find whoami.akamai.net: No answer

    It seems there is a problem with your router that you configured it incorrectly, or it has a bug.  Post a screen shot of the router page where you configured OpenDNS, and also post a link to an online user manual.

    Btw, the command netsh does not exist on Mac OS X, just on Windows, therefore you get:

    bash: netsh: command not found

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    This looks accurate. But your router doesn't seem to do what you configured, to forward your DNS queries to OpenDNS.  I would need to see the user manual.

    Or your ISP intercepts your DNS traffic and redirects it to their own DNS service.  The following command can check the latter:

    nslookup -type=txt which.opendns.com. 208.67.220.220

    If this returns "I am not an OpenDNS resolver", then your ISP intercepts your DNS traffic.

    As your ISP seems to be Comcast, it is worth to read this:
    https://support.opendns.com/hc/en-us/community/posts/115019065723 
    https://support.opendns.com/hc/en-us/articles/227988687

    0
    Comment actions Permalink
  • Avatar
    rjpack

    Thank you. Your suggestions have resolved my issue. I am now seeing my wireless devices being filtered. Thank you for your help!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I should mention for other readers that rjpack deleted most of his own comments, so reading through this thread may look strange and not easily understandable.

    0
    Comment actions Permalink

Please sign in to leave a comment.