Set Up Router (Zyxel EMG3425-Q10A) for OpenDNS But isn't working, no blocking

Comments

10 comments

  • Avatar
    rotblitz

    I need more information.  Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    ipconfig /all

     

    0
    Comment actions Permalink
  • Avatar
    jimbobdean

    C:\Users\Fam>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m89.ash"
    debug.opendns.com text =

    "flags 20 0 50 180000000000000000003950000000000000000"
    debug.opendns.com text =

    "originid 214644696"
    debug.opendns.com text =

    "actype 2"
    debug.opendns.com text =

    "bundle 11692730"
    debug.opendns.com text =

    "source 216.197.79.243:57963"

     

    C:\Users\Fam>nslookup -type=txt which.opendns.com.
    Server: ec2-23-21-43-50.compute-1.amazonaws.com
    Address: 23.21.43.50

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    opendns.com nameserver = auth3.opendns.com
    opendns.com nameserver = auth1.opendns.com
    opendns.com nameserver = auth2.opendns.com

    0
    Comment actions Permalink
  • Avatar
    jimbobdean (Edited )

    C:\Users\Fam>nslookup whoami.akamai.net.
    Server: ec2-23-21-43-50.compute-1.amazonaws.com
    Address: 23.21.43.50

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 74.125.80.4

    Windows IP Configuration


    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter 

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Mellanox ConnectX-2 Ethernet Adapter
    Physical Address. . . . . . . . . : 
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::bdbe:fd82:3422:c85d%9(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.2(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :
    DHCPv6 IAID . . . . . . . . . . . : 167772873
    DHCPv6 Client DUID. . . . . . . . : 
    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Ethernet:

    Connection-specific DNS Suffix . : zyxel.com
    Description . . . . . . . . . . . : Intel(R) Ethernet Connection (2) I218-V
    Physical Address. . . . . . . . . : 
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::dd3c:3378:8707:a418%3(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.49(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Wednesday, December 26, 2018 12:46:44 AM
    Lease Expires . . . . . . . . . . : Wednesday, December 26, 2018 12:46:43 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 37279047
    DHCPv6 Client DUID. . . . . . . . : 
    DNS Servers . . . . . . . . . . . : 23.21.43.50
    169.53.235.135
    NetBIOS over Tcpip. . . . . . . . : Enabled

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    This is the configured DNS service on your computer:

    DNS Servers . . . . . . . . . . . : 23.21.43.50
                                           169.53.235.135

    This is clearly not OpenDNS and most likely overwrites the router settings.  Or you didn't configure the router correctly.  Configure the computer to obtain the DNS server settings automatically via DHCP from the router, or configure OpenDNS on the computer.  The OpenDNS resolver addresses are 208.67.222.222 and 208.67.220.220.

    0
    Comment actions Permalink
  • Avatar
    cory.miller

    I have this issue, too. Here's the output of the command line queries:

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m41.pao"
    debug.opendns.com text =

    "flags 40020 0 50 1800000000000000000039500007E00400014C3"
    debug.opendns.com text =

    ------------------------------------------- added for clarity ----------------------------------------------

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    which.opendns.com text =

    "m9.pao"

    ------------------------------------------- added for clarity ----------------------------------------------

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    Name: whoami.akamai.net
    Addresses: 2620:0:cc3::19
    208.67.219.17

    ------------------------------------------- added for clarity ----------------------------------------------

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : DESKTOP-J4MSG9P
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : local

    Ethernet adapter Ethernet:

    Connection-specific DNS Suffix . : local
    Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
    Physical Address. . . . . . . . . : BC-30-5B-9D-11-8E
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::a984:2094:d937:6e71%13(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.48(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Sunday, June 14, 2020 1:15:12 AM
    Lease Expires . . . . . . . . . . : Sunday, June 14, 2020 7:15:12 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 62664795
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-F9-9A-46-BC-30-5B-9D-11-8E
    DNS Servers . . . . . . . . . . . : 208.67.220.220
    208.67.222.222
    192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    DNS Servers . . . . . . . . . . . : 208.67.220.220
    208.67.222.222
    192.168.1.1

    Remove 192.168.1.1 from the DNS configuration on this computer.

    Instead of “added for clarity” you better had shown the commands being executed. That would have provided true clarity.

    0
    Comment actions Permalink
  • Avatar
    cory.miller

    Sorry--my intent was to show clear delineation between each command line's output; no offense intended.

    I tried to delete the 192.168.1.1 before running the command line scripts, but the router put it back in. I'll try it again and post the results here.

    Thank you for the help.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    If this does not help, do the following things:

    Post the output of the following command here:

    netsh interface ipv4 show config

    Also post a screen shot of the router page where you have the OpenDNS resolver addresses configured.

    As you said you have the same issue as the previous report, am I right that you have a Zyxel EMG3425-Q10A router?

    0
    Comment actions Permalink
  • Avatar
    cory.miller

    We do have the same Zyxel modem/router.

    I reapplied the removal of the 192.168.1.1 address from the DNS list and verified that it stayed removed. Site black listing works as advertised now.

    Again, I appreciate your help, though it still baffles me as to why the 192.168.1.1. address popped back in.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Most likely a glitch in the router firmware...

    0
    Comment actions Permalink

Please sign in to leave a comment.