Open dns not filtering anything

Comments

8 comments

  • Avatar
    rotblitz (Edited )

    I'm not sure what instructions you followed, but it seems you followed the wrong ones.  You did not enable LPC.  Undo whatever you have done, and follow only these instructions:

    https://kb.netgear.com/25687/

    "Does this mean I have IPv6 through my internet company?"

    No, it means that OpenDNS communicates with Akamai over IPv6.  It has nothing to do with you, exept that it shows that your DNS traffic goes via OpenDNS.

    You ---> (IPv4) OpenDNS (IPv6) ---> (IPv6) whoami.akamai.net

    But yes, if you had IPv6 connectivity, this would be incompatible with LPC.  You had to disable IPv6 on the router then.

  • Avatar
    sniperskulls

    Those are exactly the instructions I followed. What makes you say I didnt? Are you seeing something wrong?

    It shows my parental controls are enabled but nothing is actually being blocked. Except if I go to internetbadguys.com its blocked. Just nothing else is blocked

  • Avatar
    rotblitz

    "What makes you say I didnt? Are you seeing something wrong?"

    Yes, if you had LPC enabled, it would show a line like this in the first command "nslookup -type=txt debug.opendns.com.":

       debug.opendns.com text =    "device yourMACaddress"

    But this does not appear.  I can see that you use OpenDNS, but only with its default settings, not with individual LPC settings so far.  Not sure how you got to use OpenDNS, but probably with configuring the OpenDNS resolver addresses on the router which is not part of the instructions.

  • Avatar
    sniperskulls

    Whenever I enable it it changes the DNS settings in my router as I would suspect. Then as I get dhcp lease from the router it assigns itself as the DNS. This isn't expected behavior in the router? It should do full DNS passthrough?

    Could this be something to do with the fact that I am setting custom mac address for the router? Or something with dhcp settings?

    I would expect the router to set itself as the DNS server since its handling dhcp. Do you have LPC enabled and that's your result?

  • Avatar
    sniperskulls

    Ok, I just set the router back to default mac address instead of using one I assigned to it. 

     

    Rebooted the router and re-enabled parental controls and I get the exact same results as above. The router assigns itself as the DNS server when handing out DHCP. so the command always returns the same results. 

     

  • Avatar
    rotblitz (Edited )

    Correct, if you enable LPC, the router DHCP-propagates itself as DNS server to the end user devices and sets itself the OpenDNS resolver addresses as forwarders.  This is the expected behavior.  Because the command output does not result in the expected output (debug.opendns.com text = "device yourMACaddress"), something must be wrong with your router or your account.

    As I do not have a Netgear router, I cannot reproduce it, but I can well imagine that changing the WAN MAC address can have an impact.  LPC works based on and relies on the router's MAC address (= device ID).  Best would be to raise a support ticket, link "Submit a request" above, so that staff can check your account and can work with you.  You may include a link to this thread in your ticket, so that they see what has been analyzed.

    Alternatively, use the normal OpenDNS Home, not LPC.

  • Avatar
    Permanently deleted user

    I posted my response on another post but this is what worked for me...I had to log into my open dns dashboard account and update my network via their website. I had a legacy open dns account before it was integrated into negear genie. I had to update my settings from there and run the open dnsupdater v.2.21 now the parental controls are working.

  • Avatar
    rotblitz

    Again, you seem to be using OpenDNS Home now, not Netgear LPC.  These services are not compatible.  You can use either the one or the other.

    Btw, not a good idea to post the same in different threads.

Please sign in to leave a comment.