OpenDNS not working on Huawei B310s-518

Comments

4 comments

  • Avatar
    rotblitz (Edited )

    "I think already the first three tests show the problem"

    No, unfortunately these traceroute outputs are rather irrelevant for your problem.  These many commands are to cover all believable problems, not especially yours. 

    "a connection via a Movistar Chile sim card"

    This may be the real root cause for your troubles.  It is often not possible to use OpenDNS and similar services in mobile networks.  OpenDNS is a service for networks you own, not for your devices in other networks which are not controllable by you.

    For example, Movistar assigns you a private IP address of probably 10.179.2.121 which cannot be registered at the OpenDNS dashboard anyway.  And the public IP address the internet sees from you (http://myip.dnsomatic.com/) is not yours but a shared one which you should not register with OpenDNS either.

    I would need to see the complete plain text output of the following diagnostic commands:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

    Also, can you post a screen shot of the router page where you have configured OpenDNS.

    "I already deactivated IPv6"

    If you have dual-stack connectivity, then this is not needed as long as you also configure the IPv6 side for OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    feelatacamahostel (Edited )

    Thank you for your answer!

    Here are the outputs of the commands:

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m10.sao1"
    debug.opendns.com text =

    "flags 20 0 70 180000000000000000007950800000000000000"
    debug.opendns.com text =

    "originid 0"
    debug.opendns.com text =

    "actype 0"
    debug.opendns.com text =

    "source 191.125.165.72:41373"

     

    Server: homerouter.cpe
    Address: 192.168.9.1

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

     

    Server: homerouter.cpe
    Address: 192.168.9.1

    Non-authoritative answer:
    Name: whoami.akamai.net
    Address: 200.28.4.130

     

    Configuration for interface "Conexión de red inalámbrica 2"
    DHCP enabled: Yes
    InterfaceMetric: 5
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Conexión de red inalámbrica"
    DHCP enabled: Yes
    IP Address: 192.168.9.100
    Subnet Prefix: 192.168.9.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.9.1
    Gateway Metric: 0
    InterfaceMetric: 25
    DNS servers configured through DHCP: 192.168.9.1
    192.168.9.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Conexión de área local"
    DHCP enabled: Yes
    InterfaceMetric: 5
    DNS servers configured through DHCP: 192.168.8.1
    192.168.8.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 50
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

    I understand, that it will maybe not possible because of the mobile internet. Sadly this is the only way to get internet here and it would be great to log and filter it with OpenDNS.

    Thank you for checking with me!

     

    ahh and the screenshot:

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Apparently your router's DNS settings are ignored if it is connected to a SIM card, because you're actually still using Movistar's DNS service (200.28.4.130 = ns1.movistar.cl).  However, if you configured OpenDNS on the computer, it would work.  Or try with configuring OpenDNS on the LAN/DHCP side of your router if this is possible.

    "it would be great to log and filter it with OpenDNS."

    Not sure if the IP address OpenDNS sees from you (191.125.165.72 = 191-125-165-72.bam.movistar.cl when you executed the command) is a shared one or a dedicated, but this would be the one needed to be registered at https://dashboard.opendns.com/settings/ to make your dashboard settings work and to make DNS stats collecting.

    If you cannot get your dashboard taking effect, you still can use the FamilyShield addresses 208.67.222.123 and 208.67.220.123 to at least get some basic predefined and static domain filtering.

    0
    Comment actions Permalink
  • Avatar
    feelatacamahostel

    Then OpenDNS is not a working solution for us. 

    There are no other DNS settings in the router and just on the computers would not solve our problem.

    We have to search for something else.

    But thank you very much for your time and help!

    0
    Comment actions Permalink

Please sign in to leave a comment.