DDNS

Comments

9 comments

  • Avatar
    rotblitz

    A DDNS client for use with OpenDNS must at least support one of these DDNS services: OpenDNS, DNS-O-Matic, or "custom / user defined".  If it doesn't, you don't need to think about using it for OpenDNS.

    The "domain name" would be your network label from https://dashboard.opendns.com/settings/ in case of OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    ingstyke

    Thank you for your reply.

    I am desperately trying to use the OpenDns servers in my router, instead of those of my ISP, which I think are causing my problem. Although I can input the OpenDns settings in my router as optional fields, I don't seem to be able to change the ISP's dns servers at all. When I run "ipconfig /all" it shows the OpenDns server settings.

    I am struggling to understand what the problem is. I do hope that you can clarify it for me.

    Thank you.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    It seems I misunderstood you, because it doesn't seem to be about DDNS, but about the DNS settings on your router.  These are two totally different things.

    "When I run "ipconfig /all" it shows the OpenDns server settings."

    Well, then you should be using OpenDNS already.  Check it at http://welcome.opendns.com/
    If you're using OpenDNS, what is the evidence of a problem?  I cannot explain a problem which I don't know.

    If you want to know where to configure the OpenDNS resolver addresses on your TP Link Archer V900, then you have to provide me with a link to an online user manual, because I couldn't find anything about this specific model.  It even doesn't seem to exist.

    0
    Comment actions Permalink
  • Avatar
    ingstyke

    It seems I may have confuased things by not giving a full explanation of the problem!

    For months I have had a problem of random failures to connect to the internet. I get the error "dns probe finished no internet". My ISP (Plusnet in the UK) says there is no problem with my account. Research on the internet suggests this problem may be with the DNS servers at the ISP, so I decided to try OpenDns. Having bought and set up a new router I now find that I am unable to change the dns servers to use OpenDns instead of the ISP servers. The LAN settings on the router show the ISP server addresses and I don't seem to be able to override these. I have changed the dns servers on my PC, but the problem continues!

    Any suggestions would be gratefully received. I attach a link to the router user manual.

    Thank you.

    https://static.tp-link.com/res/down/doc/Archer_VR900(EU)_V1_UG.pdf 

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Ah, the router model is VR900, not V900 as you said before.  That's the reason why I could not find it.

    "I now find that I am unable to change the dns servers to use OpenDns instead of the ISP servers."

    It doesn't look like that your router can support configuring static DNS server addresses like the ones from OpenDNS.  But you can still configure your end user devices.

    "I have changed the dns servers on my PC, but the problem continues!"

    I need more information.  Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

     

    0
    Comment actions Permalink
  • Avatar
    ingstyke

    Microsoft Windows [Version 10.0.17763.316]
    (c) 2018 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    *** resolver2.opendns.com can't find debug.opendns.com.: Non-existent domain

    C:\WINDOWS\system32>nslookup -type=txt which.opendns.com.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    opendns.com nameserver = auth3.opendns.com
    opendns.com nameserver = auth1.opendns.com
    opendns.com nameserver = auth2.opendns.com
    auth1.opendns.com AAAA IPv6 address = 2620:119:30::53
    auth1.opendns.com internet address = 208.69.39.2
    auth2.opendns.com AAAA IPv6 address = 2a04:e4c0:53::53
    auth2.opendns.com internet address = 146.112.60.53
    auth3.opendns.com internet address = 208.69.39.2

    C:\WINDOWS\system32>nslookup whoami.akamai.net.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    Name: whoami.akamai.net
    Addresses: 2a04:e4c0:10::76
    77.234.43.211


    C:\WINDOWS\system32>netsh interface ipv4 show config

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.1.104
    Subnet Prefix: 192.168.1.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.1.1
    Gateway Metric: 0
    InterfaceMetric: 25
    Statically Configured DNS Servers: 208.67.222.222
    208.67.220.220
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None


    C:\WINDOWS\system32>

    Hope this helps!!

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, this helps!

    You have enabled an option in your Avast or AVG appliance, probably called Fake Site, Real Site or Secure DNS which hi-jacks your DNS traffic and redirects it to Avast's DNS service.  You simply disable this option, and it should work then. 
    Check it here after the change: http://welcome.opendns.com/

    0
    Comment actions Permalink
  • Avatar
    ingstyke

    Wow!!

    I disabled Fake Site in AVG and OpenDns worked straight away. I did not enable this setting, perhaps it is a default setting?

    In your opinion should this solve the issue of "dns probe finished no internet"?

    I am truly grateful for your help and your patience.

    Very many thanks

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Yes, this Fake Site setting is most likely the default when installing.  You wanted to be protected by this appliance, and this is what they mean to do with this measure.

    This "dns probe finished no internet" can have several reasons.  Your internet connection may be unstable which would be your ISP, in which case any DNS service would be impacted.  Now that you know that you used Avast's DNS service (not your ISP's) before, it could also indicate a specific problem with Avast's DNS service.  You will see if you don't face the problem again with another DNS service like OpenDNS going further.

    0
    Comment actions Permalink

Please sign in to leave a comment.