open dns only works on a pc

Comments

15 comments

  • Avatar
    rotblitz

    I need more information.  Copy & paste the complete plain text output of the following diagnostic commands to here, from a PC where it does not work.

    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config

    Also, post a screen shot of the router page where you have configured OpenDNS.

    0
    Comment actions Permalink
  • Avatar
    hr_terrenos

    Router configuration

     

    verification on my pc

    In a moment I send him the codes

    0
    Comment actions Permalink
  • Avatar
    hr_terrenos

    codes

    nslookup -type=txt debug.opendns.com.

    nslookup whoami.akamai.net.

    netsh interface ipv4 show config

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    This is not plain text, but screen shot images. :(

    Regardless, unlike you said, IPv6 is *not* disabled , but you're using 2806:10b8:ffff:2::e as DNSv6 server address which is your ISP's DNS service.

    Instead of disabling IPv6, you better configure IPv6 with the DNS server addresses ::ffff:d043:dedc and ::ffff:d043:dcde

    0
    Comment actions Permalink
  • Avatar
    hr_terrenos

    Sorry I had not noticed, I've already solved thank you very much, one more question in mobile phones knows what could be the problem that does not connect?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Are you talking about OpenDNS on mobile phones?  Can you be more specific about "does not connect"?  Where does it not connect to?

    Also, OpenDNS is a service for networks you own, not for your devices in other networks.

    0
    Comment actions Permalink
  • Avatar
    hr_terrenos

    Yes, I mean that mobile devices are in the same network as PCs but these are not affected by restrictions

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    They are not?  Visit http://welcome.opendns.com/ on these devices to ensure that they are using OpenDNS at all.

    If they are not using OpenDNS, then check their network settings to ensure that they obtain them automatically via DHCP from the router, and that they do not have alternative DNS server addresses configured.  There are also apps which establish a dummy VPN connection in order to use custom DNS services.  This would circumvent OpenDNS as well.

    0
    Comment actions Permalink
  • Avatar
    hr_terrenos

    Yes, cell phones get them automatically by DHCP and I'm not using any kind of VPN, so I do not understand what the fault could be

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Well, maybe there is no fault.  What are the evidences for faults?  Are they not using OpenDNS?

    Also, what OSes are these mobile devices?  Android, iOS, Windows, or what?  And what browsers are you using on them?

    0
    Comment actions Permalink
  • Avatar
    hr_terrenos

    They are an Android system, they use Chrome as a browser and when I check if they are using opendns I get an x, but they are connected to the same network with dhcp, the pc works well

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    "when I check if they are using opendns I get an x"

    Ah yes, they are not using OpenDNS at all!  Disable the "Data Saver" option in Chrome.  This is "any kind of VPN" or proxy which circumvents any other configured DNS service like OpenDNS. 
    In addition, you may want to add compress.googlezip.net and check.googlezip.net to your "always block" list.

    Btw, as almost, the knowledge base is your friend: https://support.opendns.com/hc/en-us/articles/227989047
    You must just read it.  You did not need to raise it here again.

    0
    Comment actions Permalink
  • Avatar
    marlinputnam8745

    If they are not using OpenDNS, then check their network settings to ensure that they obtain them automatically via DHCP from the router and that they do not have alternative DNS server addresses configured.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, this is exactly what I said above a while ago.

    0
    Comment actions Permalink
  • Avatar
    hr_terrenos

    if they have them, the chrome settings do not work, sometimes out of nowhere you want to enter the sites and if you block them, and other days it just does not work.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.