Linksys e1200 router- opendns not working

Comments

6 comments

  • Avatar
    rotblitz (Edited )

    Yes, you can register also a static IP address at the dashboard, of course.  In this case you do not run an updater.

    I cannot answer Q2 without having more information.  Copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 208.67.220.220
    nslookup -type=txt which.opendns.com.
    nslookup whoami.akamai.net.
    netsh interface ipv4 show config
    netsh interface ipv6 show dnsservers

    Or are you affected by the Linksys firmware bug?  (Model E1200 is not known for this.)

    Read here: https://support.opendns.com/hc/en-us/articles/228008007

    If not working, there is a known bug in recent Linksys firmware versions that prevents DNS settings from applying. To check if your device is affected, check the router stats under Troubleshooting -> Status tab. If the DNS addresses have not changed to 208.67.220.220, 208.67.222.222 and 208.67.222.220, your router is being affected by the bug. 

    If the OpenDNS addresses are not displaying here, the solution at this time is to roll back the firmware version of your router.

    0
    Comment actions Permalink
  • Avatar
    m3finity159

    Good Day Rotblitz,

    I do appreciate the help. Thanks a lot.

    Down below is the result of the command that you gave.

    - What should I be looking for within the result to debug the problem?

    Thanks again.

     

    Microsoft Windows [Version 10.0.17134.590]
    (c) 2018 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>nslookup -type=txt debug.opendns.com. 208.67.220.220
    Server: resolver2.opendns.com
    Address: 208.67.220.220

    *** resolver2.opendns.com can't find debug.opendns.com.: Non-existent domain

    C:\WINDOWS\system32>nslookup -type=txt which.opendns.com.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."

    opendns.com nameserver = auth1.opendns.com
    opendns.com nameserver = auth2.opendns.com
    opendns.com nameserver = auth3.opendns.com
    auth1.opendns.com AAAA IPv6 address = 2620:119:30::53
    auth1.opendns.com internet address = 208.69.39.2
    auth2.opendns.com AAAA IPv6 address = 2a04:e4c0:53::53
    auth2.opendns.com internet address = 146.112.60.53
    auth3.opendns.com internet address = 208.69.39.2

    C:\WINDOWS\system32>nslookup whoami.akamai.net.
    Server: resolver1.opendns.com
    Address: 208.67.222.222

    Non-authoritative answer:
    Name: whoami.akamai.net
    Addresses: 2a04:e4c0:20::69
    119.81.145.165


    C:\WINDOWS\system32>netsh interface ipv4 show config

    Configuration for interface "Local Area Connection* 3"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 4"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Ethernet"
    DHCP enabled: Yes
    IP Address: 192.168.0.122
    Subnet Prefix: 192.168.0.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.0.1
    Gateway Metric: 0
    InterfaceMetric: 35
    Statically Configured DNS Servers: 208.67.222.222
    208.67.220.220
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Bluetooth Network Connection"
    DHCP enabled: Yes
    InterfaceMetric: 65
    Statically Configured DNS Servers: 8.8.8.8
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wi-Fi"
    DHCP enabled: Yes
    IP Address: 192.168.8.107
    Subnet Prefix: 192.168.8.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.8.1
    Gateway Metric: 0
    InterfaceMetric: 70
    DNS servers configured through DHCP: 192.168.8.1
    192.168.8.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: None
    Statically Configured WINS Servers: None


    C:\WINDOWS\system32>netsh interface ipv6 show dnsservers

    Configuration for interface "Local Area Connection* 3"
    DNS servers configured through DHCP: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Local Area Connection* 4"
    DNS servers configured through DHCP: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Bluetooth Network Connection"
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only

    Configuration for interface "Wi-Fi"
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
    Statically Configured DNS Servers: None
    Register with which suffix: None

     

     

    0
    Comment actions Permalink
  • Avatar
    m3finity159

    I have checked the router status and it is set to openDns addresses.

    Q1. Do i also need to set IPV6 configuration or else I disable it?

    Q2. My local management access is set to HTTP, and there is also HTTPS option. Which one?

    Q3. Does upgrading my router's firmware will somewhat solve this problem?

    THanks.

     

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You have enabled an option in your Avast or AVG appliance, probably called Fake Site, Real Site or Secure DNS which hi-jacks your DNS traffic and redirects it to Avast's DNS service.  You simply disable this option, and it should work then. 
    Check it here after the change: http://welcome.opendns.com/

    Re Q1: It doesn't seem that you have IPv6 connectivity from your ISP.

    Re Q2: I do not understand.  What has this to do with OpenDNS?

    Re Q3: Never mind.

    0
    Comment actions Permalink
  • Avatar
    m3finity159

    Thanks for the help. It finally worked. My AV is actually Avast Premier.Thanks you so much!!!

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Welcome!

    0
    Comment actions Permalink

Please sign in to leave a comment.