Not able to setup OpenDNS on D-Link 880L

Comments

4 comments

  • Avatar
    rotblitz (Edited )

    There is a bunch of issues.

    • On the router you have your internet connection configured as type "Static IP" address. and the IP address 192.168.1.2 is a private IP address.  Are you sure this is correct?  Is there another device like a DSL or cable modem before?
      (See e.g. page 34 of ftp://ftp.dlink.ca/PRODUCTS/DIR-880L/DIR-880L_REVA_MANUAL_1.00_EN.PDF)
        
    • It seems your're connected via network interface "Ethernet 2" to your router, but this interface has been manually configured:
       
      Statically Configured DNS Servers: 172.20.108.11  (dcdkrtv01.cpcorp.net)
                                                              172.20.208.11
       
      These private corporate resolvers overwrite any router DNS settings.  On the computer you would have to obtain the DNS server addresses automatically via DHCP from the router, or you must configure OpenDNS explicitly.  Could it be that you're using a VPN connection here?  OpenDNS or your VPN may not work when using a corporate VPN connection, and OpenDNS definitely cannot work with the current configuration.
       
    • Your network interface "Wi-Fi" gets non-OpenDNS resolvers from a DHCP server:
       
      DNS servers configured through DHCP: 89.150.129.22
                                                                      89.150.129.10
       
      These seem to be the resolvers of a Danish ISP.  Any idea how this can happen?  Do you have another DHCP server inside your network beside the router?  Or do you have configured these resolvers on the DHCP/LAN side of the router?
       
    • Your public IP address (2.110.64.233 when you executed the commands) is not yet registered at https://dashboard.opendns.com/settings/ so your dashboard settings cannot take effect anyway.

    I listed enough issues, but there may be even more...
    It looks like you didn't fully explain your environment.  There seems to be more than just a router and a computer, like a VPN connection or a NAT-modem or such.  And this causes that OpenDNS does not work for you, because you don't use it yet.

  • Avatar
    robinson449

    Thanks for your reply - so clearly I am not an expert in this area.

    I was using a different DNS service up until yesterday, but it stopped working so I am trying OpenDNS.  

    Let me explain the environment:

    Modem, connected to the D-Link Router.  The computer I used to run the command is a company computer that runs an automatic VPN program once connected to the internet.  However, the DNS is not connecting properly when checked via my iPhone as well.  

    I will switch my router to dynamic IP, will that help?

    What other steps do you recommend I try?

  • Avatar
    rotblitz

    That is pretty difficult to assist with in a forum like this, but let's try.

    Your modem: This device seems to be in NAT mode.  Can you switch it to bridged mode to avoid double-NAT?  Why do you need this modem at all?  Can't you connect the router directly?

    Your router: If you switch your modem to bridged mode or take it out of the chain, you probably need to change the router settings from "Static IP" to "Dynamic IP (DHCP)".
    Also, your router currently hands out your ISP's DNS resolver addresses to end user devices, most likely because you have manually configured them on the LAN/DHCP side of your router.  This is the reason why it doesn't work e.g. on your iPhone and other end user devices.  You must change this by removing the ISP's resolver addresses in the router LAN/DHCP configuration, or whatever is needed to prevent this ISP DNS usage from happening.

    Your computer: As I said, you currently use your corporate (internal) DNS servers, because these are manually configured on the network interface.  You could change these to the OpenDNS resolver addresses, but this would have the effect that corporate internal names and network resources cannot longer be resolved, because OpenDNS cannot resolve internal network names.  So using OpenDNS with your VPN connection for company purposes does not seem to be an option.  You should stop the VPN connection to become able using OpenDNS on this computer.  Else you simply cannot use OpenDNS on it.

    OpenDNS dashboard: Visit https://dashboard.opendns.com/settings/ to add a network and/or to update it with your public IP address.  Only then your dashboard settings can take effect.  Whatever, as long as you don't use OpenDNS, your dashboard and its settings are irrelevant without any effect.

    You can check at any time if you're using OpenDNS by visiting http://welcome.opendns.com/ on every end user device.

  • Avatar
    rotblitz

    "I was using a different DNS service up until yesterday"

    Are you really sure you did?  My suspicion is that you used your company DNS service on the PC and your ISP's DNS service on the other devices, as you do now, not this other DNS service.

Please sign in to leave a comment.