How to update IP from OpenWRT?

Comments

3 comments

  • Avatar
    rotblitz

    Your problem is that you posted this in an OpenDNS forum instead of checking the OpenWRT ressources where this can be easily found.

    It doesn't look like that OpenWRT supports OpenDNS directly.  You may have to send your DDNS updates through DNS-O-Matic to OpenDNS.

    See https://openwrt.org/docs/guide-user/services/ddns/client

  • Avatar
    mountaindew

    I have asked the question in both OpenDNS and OpenWRT forums, just in case I did not get any reply.

     

    DNS-O-Matic is already linked but it still asks for hostname and domain

  • Avatar
    rotblitz (Edited )

    This screen shot significantly differs from the documentation at openwrt.org.  :(

    "Under the DDNS configuration section I selected OpenDNS as service provider"

    At the openwrt.org article OpenDNS is not listed as service provider, just DNS-O-Matic is.

    "DNS-O-Matic is already linked"  -  No, it is not, but OpenDNS.

    Let's go through:

    Lookup Hostname: This must be an FQDN to validate your IP address.  Definitely, myip.dnsomatic.com is not a hostname of yours where your current IP address could be validated with.  This domain is useful only for checking your IP address with a URL in a web browser: http://myip.dnsomatic.com/
    Instead you must enter a hostname of a DDNS service you have subscribed to, and which you must keep updated in addition to OpenDNS.  (OpenDNS is not a DDNS service, it just uses the same update method.)

    DDNS Service Provider: opendns.com seems to be correct, although not mentioned at openwrt.org.

    Domain: This replaces the domain in the update URL.  In case of OpenDNS it is your network label.

    Use HTTP Secure: You must send your updates over HTTPS.  Only this is accepted by OpenDNS.

    Also, what settings are possible under "Advanced Settings"?  Is this also DDNS related?

    Again, your best bet is to contact support for this specific DDNS client which I could not find at openwrt.org.

Please sign in to leave a comment.