OpenDNS not blocking - nslookup returning my router IP

Comments

7 comments

  • Avatar
    rotblitz (Edited )

    I would need to see the complete command output to tell you what you are doing wrong, and the output of other commands like:

    nslookup whoami.akamai.net.

    It is correct that the nslookup command returns the internal IP address of the router if you configured a 3rd party DNS service on the WAN side of the router.  Did you expect something different?

    But, as you seem to have a Netgear router, do you want to use LPC or just plain OpenDNS?

    0
    Comment actions Permalink
  • Avatar
    adsingh

    Sorry for the late response. Below is what I get after running these commands.

    nslookp

    Default Server: UnKnown
    Address: 192.168.1.1

    whoami.akamai.net.
    Server: UnKnown
    Address: 192.168.1.1

    Name: whoami.akamai.net
    Address: 2620:0:cc5::73

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Well, you did not show the command output of "nslookup -type=txt debug.opendns.com.", so the diagnostics are very limited.  And you forgot to answer my question regarding LPC.

    I can see that your DNS traffic reached OpenDNS DC Chicago (2620:0:cc5::73 = m53.chi.opendns.com).  Why do you think you're doing something wrong?  I do not think so, check at http://welcome.opendns.com/

    0
    Comment actions Permalink
  • Avatar
    adsingh

    Hi here is the output for nslookup -type=txt debug.opendns.com. The reason I think something is wrong is that domains are not getting blocked. Thanks.

     

    Server: UnKnown
    Address: 192.168.1.1

    Non-authoritative answer:
    debug.opendns.com text =

    "server m49.chi"
    debug.opendns.com text =

    "device 000026CD49179F69"
    debug.opendns.com text =

    "flags 40422 0 8010 1800000000000000000039401007E00400014C3"
    debug.opendns.com text =

    "originid 115675804"
    debug.opendns.com text =

    "actype 1"
    debug.opendns.com text =

    "bundle 115675804"
    debug.opendns.com text =

    "source 73.73.64.199:54781"

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    You have Netgear LPC enabled, but you're also using OpenDNS Home in parallel, i.e. your IP address 73.73.64.199 is registered with an OpenDNS network ID 115675804.  These two services are incompatible, and you can use only one of it.  And this is the reason why your settings do not work as expected.  I cannot see if this is your OpenDNS network or another, but it is worth to check at https://dashboard.opendns.com/settings/ if you have an OpenDNS network configured and to delete it from there.
    Your LPC dashboard is only at https://netgear.opendns.com/

    If you cannot solve your problem, then staff must check your account and this IP address registration.  You raise a support ticket, link "Submit a request" above.

    0
    Comment actions Permalink
  • Avatar
    adsingh

    Thanks. So how do I block domains from LPC? It takes to OpenDNS page (from parental controls) however there is no option to add domains that I want to block. I can only choose the categories I want to be blocked.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    In this case you better disable LPC and configure OpenDNS Home for use.

    0
    Comment actions Permalink

Please sign in to leave a comment.