OpenDNS not blocking instant messages

Comments

5 comments

  • Avatar
    rjkenterprisenumber7

    Also, I put your DNS into my iPhone directly and it still isn’t blocking WhatsApp

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    "your instant messaging blocking service"
    "your DNS"

    I do not offer such things.  You are talking to other users here, not to staff.

    Are you using OpenDNS now?  Check at http://welcome.opendns.com/ on all devices where you want to use OpenDNS.

    If yes, is your public IP address registered at https://dashboard.opendns.com/settings/ ?
    Did you enter the domain names whatsapp.com and whatsapp.net into your "always block" list, or did you select at least category Instant Messaging for blocking?

    0
    Comment actions Permalink
  • Avatar
    rjkenterprisenumber7

    I did not put the URLS into OpenDNS’s blacklist, but I put them into my Pi-hole’s blacklist. I could still text on WhatsApp when the URLs were blocked on my Pi-Hole. I have selected the instant messaging category for blocking, but I can still use WhatsApp

    0
    Comment actions Permalink
  • Avatar
    rjkenterprisenumber7

    In case you are wondering, a Pi-Hole is an ad-blocking service using DNS. In the settings though, you can put another DNS that the Pi-Hole can redirect to since the Pi-Hole doesn’t have a DNS Library

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "I did not put the URLS into OpenDNS’s blacklist"

    Sure not, because these are not URLs, but domain names.  You can block domain names only with a DNS service, not URLs.

    "I put them into my Pi-hole’s blacklist. I could still text on WhatsApp when the URLs were blocked on my Pi-Hole"

    Fine.  But this has nothing to do with OpenDNS then, and you better visit a Pi-Hole forum.

    "I have selected the instant messaging category for blocking, but I can still use WhatsApp"

    Then what I wrote above applies.  You had to ensure that you really use OpenDNS, i.e. that your DNS queries go to them.  I have provided you with the diagnostic page to be used for checking this.  If the device has also a CLI, you can check it also with some diagnostic commands. 

    Only in case your device is using OpenDNS, you ensure that your IP address is registered, and that you have blocked the related category or domains.  It works then!

    0
    Comment actions Permalink

Please sign in to leave a comment.