OpenDNS Not Working With Spectrum Modem

Comments

18 comments

  • Avatar
    rotblitz

    Post a screenshot of the router page where you configured OpenDNS, so that I see what you did.

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    That’s fine. Now copy & paste the complete plain text output of the following diagnostic commands to here:

    nslookup -type=txt debug.opendns.com. 
    nslookup whoami.akamai.net.

     

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    NSLOOKUP -TYPE=TXT DEBUG.OPENDNS.COM

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    opendns.com
    primary name server = auth1.opendns.com
    responsible mail addr = noc.opendns.com
    serial = 1571911927
    refresh = 16384 (4 hours 33 mins 4 secs)
    retry = 2048 (34 mins 8 secs)
    expire = 1048576 (12 days 3 hours 16 mins 16 secs)
    default TTL = 2560 (42 mins 40 secs)

    NSLOOKUP WHOAMI.AKAMAI.NET

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Name: whoami.akamai.net
    Address: 68.114.44.169

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    As can be clearly seen, you are using Charter‘s DNSv6 service, not OpenDNS. You must configure also IPv6 with DNS addresses from the following list:
    ::ffff:d043:dedc   ::ffff:d043:dcde   ::ffff:d043:dede   ::ffff:d043:dcdc

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    I don't know where to put those entries. The categories listed for IPv6 on my router are:

     

    Delegated Prefix
    Lan IPv6 Address
    Wan IPv6 Address
    First IPv6 DNS Server
    Second IPv6 DNS Server

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    As this is about DNS, you enter the addresses into the two DNS server fields, of course. What else?

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    It didn't look right but I put the entries in.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    This looks fine. Does it filter now?

    Howewer, I see you prefer FamilyShield, so change it to
    ::ffff:d043:de7b    ::ffff:d043:dc7b

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    It looks like it's working now. I had to restart the router for the changes to work. I'll change the DNS stuff and see if it still works.

     

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    The filter sometimes takes a while to kick in and it is not showing the OpenDNS "This domain is blocked" message. What I usually get is the following message:

    Your connection is not private
    Attackers might be trying to steal your information from [DOMAIN]

    The current IPV4 DNS addresses are 208.67.222.123 and 208.67.220.123. The current IPV6 DNS addresses are ::ffff:d043:de7b and ::ffff:d043:dc7b.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Yes, that's normal if you block domains of HTTPS sites and didn't download the Cisco Root CA.

    See https://support.opendns.com/hc/en-us/articles/227987007

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    The DNS numbers are on but the filter is not working again. This is what came up from the nslookup commands I ran:

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    opendns.com
    primary name server = auth1.opendns.com
    responsible mail addr = noc.opendns.com
    serial = 1587717664
    refresh = 16384 (4 hours 33 mins 4 secs)
    retry = 2048 (34 mins 8 secs)
    expire = 1048576 (12 days 3 hours 16 mins 16 secs)
    default TTL = 2560 (42 mins 40 secs)

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Name: whoami.akamai.net
    Address: 68.114.44.177

    Please see the attached screenshots.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    You're using Charter's DNSv6 service again.

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    As you earlier said "I had to restart the router for the changes to work" it may be that another router restart is necessary now.

    Your router configuration looks fine, but the router doesn't seem to do its job, so it is not an OpenDNS problem, but a router problem.  If the router restart does not help, you could try with disabling IPv6, or you could contact your router's support.

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    I restarted the router. Now the issue is that the filter works on my phone but not my laptop.

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Post the command outputs from this laptop again please. And in addition:

    netsh int ipv4 show config
    netsh int ipv6 show dns

    0
    Comment actions Permalink
  • Avatar
    mister-andre

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    opendns.com
    primary name server = auth1.opendns.com
    responsible mail addr = noc.opendns.com
    serial = 1587820168
    refresh = 16384 (4 hours 33 mins 4 secs)
    retry = 2048 (34 mins 8 secs)
    expire = 1048576 (12 days 3 hours 16 mins 16 secs)
    default TTL = 2560 (42 mins 40 secs)

     

     

    Server: rns01.charter.com
    Address: 2607:f428:ffff:ffff::1

    Name: whoami.akamai.net
    Address: 68.114.44.169

     

     


    Configuration for interface "Local Area Connection"
    DHCP enabled: Yes
    InterfaceMetric: 5
    DNS servers configured through DHCP: 10.30.50.25
    10.30.50.30
    Register with which suffix: Primary only
    WINS servers configured through DHCP: 10.30.50.25

    Configuration for interface "Local Area Connection* 1"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Local Area Connection* 2"
    DHCP enabled: Yes
    InterfaceMetric: 25
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Wireless Network Connection"
    DHCP enabled: Yes
    IP Address: 192.168.1.188
    Subnet Prefix: 192.168.1.0/24 (mask 255.255.255.0)
    Default Gateway: 192.168.1.1
    Gateway Metric: 0
    InterfaceMetric: 50
    DNS servers configured through DHCP: 192.168.1.1
    Register with which suffix: Primary only
    WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
    DHCP enabled: No
    IP Address: 127.0.0.1
    Subnet Prefix: 127.0.0.0/8 (mask 255.0.0.0)
    InterfaceMetric: 75
    Statically Configured DNS Servers: None
    Register with which suffix: Primary only
    Statically Configured WINS Servers: None

     

     


    Configuration for interface "Local Area Connection"
    DNS servers configured through DHCP: None
    Register with which suffix: Primary only

    Configuration for interface "Local Area Connection* 1"
    DNS servers configured through DHCP: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Local Area Connection* 2"
    DNS servers configured through DHCP: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Configuration for interface "Wireless Network Connection"
    DNS servers configured through DHCP: 2607:f428:ffff:ffff::1
    2607:f428:ffff:ffff::2
    Register with which suffix: Primary only

    Configuration for interface "Loopback Pseudo-Interface 1"
    Statically Configured DNS Servers: fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Register with which suffix: Primary only

    Is there any way for me to erase or reset the 'Configuration for interface "Local Area Connection"' listing?

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You do not need to erase or reset an interface. Your problem is the router. As you can see, it hands out the wrong IPv6 addresses 2607:f428:ffff:ffff::1 and 2607:f428:ffff:ffff::2, not the ones you configured. The workaround would be to configure the correct addresses manually on the laptop.

    0
    Comment actions Permalink

Please sign in to leave a comment.