How to configure Eero router to OpenDNS servers

Comments

10 comments

  • Avatar
    rotblitz

    This is rather not an OpenDNS question, but a router question. Nearly nobody knows your router. Nevertheless...

    Copy & paste the complete plain text output of the following diagnostic commands to here.
    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.

    0
    Comment actions Permalink
  • Avatar
    jkrouse

    1) nslookup -type=txt debug.opendns.com gives as follows:

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Non-authoritative answer:
    debug.opendns.com text =

    "server m45.ash"
    debug.opendns.com text =

    "flags 40020 0 70 180000000000000000007950800000000000000"
    debug.opendns.com text =

    "originid 0"
    debug.opendns.com text =

    "actype 0"
    debug.opendns.com text =

    "source 64.121.187.50:54895"

    2) nslookup whoami.akamai.net gives as follows:

    Server: resolver2.opendns.com
    Address: 208.67.220.220

    Name: whoami.akamai.net
    Address: 2620:0:ccb::77

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    All good, except that your IP address 64.121.187.50 is not registered at your dashboard.

    0
    Comment actions Permalink
  • Avatar
    jkrouse

    How do I do that?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    You visit https://dashboard.opendns.com/settings/ and update your network with the IP address information. Ensure that you run an update client doing this automatically going further.

    0
    Comment actions Permalink
  • Avatar
    jkrouse

    Thank you so much. I updated the client and now all filters are working!

    0
    Comment actions Permalink
  • Avatar
    matthew.levey

    i am having the same issue but whe nI type the suggested commands into Terminal on my Mac I get:

    1) nslookup -type=txt debug.opendns.com

    Server: 2001:4860:4860::8884

    Address: 2001:4860:4860::8884#53

     

    Non-authoritative answer:

    *** Can't find debug.opendns.com: No answer

     

    Authoritative answers can be found from:

    opendns.com

    origin = auth1.opendns.com

    mail addr = noc.opendns.com

    serial = 1585789538

    refresh = 16384

    retry = 2048

    expire = 1048576

    minimum = 2560

     

    2) nslookup whoami.akamai.net.

    Server: 2001:4860:4860::8884

    Address: 2001:4860:4860::8884#53

     

    Non-authoritative answer:

    Name: whoami.akamai.net

    Address: 18.220.203.161

     

    I'd note that 2001:4860:4860::8884 and 888 are my iPv6 Primary and Secondary addresses.  my iPv4 is 74.68.106.201

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    "i am having the same issue"

    Do you also have an Eero router?  Or why do you think you have the same issue, therefore posting in this thread instead of opening a new one?  Else I do not see that you have the same or similar issue.

    You're using a DNSv6 service probably from your ISP, not OpenDNS.  You must also configure the IPv6 side on your Eero router with DNS server addresses from the following list:
    ::ffff:d043:dedc   ::ffff:d043:dcde   ::ffff:d043:dede   ::ffff:d043:dcdc

    0
    Comment actions Permalink
  • Avatar
    jkrouse

    I did not find that using Eero's default iPv6 addresses prevented its filters from working, but maybe that is because I am not using Macs. I tried entering 2 of the 4 addresses you gave above (rotblitz), but Eero does not accept them as valid

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    "Eero's default iPv6 addresses prevented its filters from working"

    These do not exist.  Same as with IPv4, IPv6 addresses are assigned by your ISP and are not default, but usually dynamic.  And assigned IPv4 or IPv6 addresses cannot prevent filters from working.  And this has nothing to do with Macs either.

    "Eero does not accept them as valid"

    That's bad.  Then your only other option is to disable IPv6 connectivity altogether.  Else you will not be using OpenDNS and/or your dashboard settings.

    0
    Comment actions Permalink

Please sign in to leave a comment.