Not blocking adult sites

Comments

16 comments

  • Avatar
    rotblitz

    Ensure that your IP address is correctly registered at your dashboard.

    0
    Comment actions Permalink
  • Avatar
    danio368

    I have checked already. The IP address on the dashboard is correct. It is actually set dynamically with OpenDNS updater.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    What real adult site did you test? Did you ensure that it is categorized accordingly?

    0
    Comment actions Permalink
  • Avatar
    danio368

    Pornhub, youporn. I haven't checked, but would be surprised if they are not blocked.
    I used a custom filtering (blocking porn, nude...). I changed to high filtering, with no difference

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Copy & paste the complete plain text output of the following diagnostic commands to here.
    nslookup -type=txt debug.opendns.com.
    nslookup whoami.akamai.net.
    nslookup www.pornhub.com.
    nslookup www.youporn.com.

    Also, what browser are you using?

    0
    Comment actions Permalink
  • Avatar
    danio368

    C:\Users\Nicolas>nslookup -type=txt debug.opendns.com
    Serveur : resolver1.opendns.com
    Address: 2620:119:35::35

    Réponse ne faisant pas autorité :
    debug.opendns.com text =

    "server r7.cdg1"
    debug.opendns.com text =

    "flags 40020 0 70 180000000000000000007950800000000000000"
    debug.opendns.com text =

    "originid 0"
    debug.opendns.com text =

    "actype 0"
    debug.opendns.com text =

    "source [2a01:cb04:5b1:b700:34a5:c462:a0c5:c459]:56598"

     

    C:\Users\Nicolas>nslookup whoami.akamai.net
    Serveur : resolver1.opendns.com
    Address: 2620:119:35::35

    Nom : whoami.akamai.net
    Address: 2a04:e4c0:12::68

     

     

    C:\Users\Nicolas>nslookup www.pornhub.com
    Serveur : resolver1.opendns.com
    Address: 2620:119:35::35

    Réponse ne faisant pas autorité :
    Nom : pornhub.com
    Address: 66.254.114.41
    Aliases: www.pornhub.com

     

     

    C:\Users\Nicolas>nslookup www.youporn.com
    Serveur : resolver1.opendns.com
    Address: 2620:119:35::35

    Réponse ne faisant pas autorité :
    Nom : youporn.com
    Address: 66.254.114.79
    Aliases: www.youporn.com

     

     

    0
    Comment actions Permalink
  • Avatar
    danio368

    PC is Win8. Browser Firefox, but also tried Internet Explorer with the same results

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    You're using the following DNS service:

    Serveur : resolver1.opendns.com
    Address: 2620:119:35::35

    Easy to fix.  The OpenDNS IPv6 resolver addresses 2620:119:35::35 and 2620:119:36::36 do not and cannot take care about your dashboard settings, because you cannot register your IPv6 address [2a01:cb04:5b1:b700:34a5:c462:a0c5:c459] at the dashboard yet.  Use resolver addresses from the following list then to configure the IPv6 side, i.e. replace 2620:119:35::35 and 2620:119:36::36 accordingly: 
    ::ffff:d043:dedc   ::ffff:d043:dcde  ::ffff:d043:dede   ::ffff:d043:dcdc

    So my first statement was right: you didn't register your IP address at your dashboard (because you couldn't). :)

    0
    Comment actions Permalink
  • Avatar
    danio368

    OK thanks a lot, that does work now. Great. I must say I am not too familiar with IPv6, and actually didn't whether I should configure the IPv6 option.

    I now have tried configuring and Android phone, and I guess I am running into the same problem. I followed the setup guide I found online, entering the IPv4 addresses of the DNS servers. This does not work. Would there be a guide for setting up Android with IPv6 (hope my question makes sense) ?

    If not, I guess deactivating IPv6 would be an option (I can do that with my provider).

    Thanks again for your help.

    0
    Comment actions Permalink
  • Avatar
    danio368

    I think I have progressed a bit on the android question. The phone I was trying on is using Android 9. I figured out that in Android 9, I should use the Private DNS setting. It tried with adult-filter-dns.cleanbrowsing.org and it does work.

    I would however rather use Opendns, which I can configure as I want, but couldn't find the hostname I should use in the private DNS setting.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I need to understand more what you want to achieve to work this one out.

    1. Where do you have the OpenDNS resolver addresses (IPv4 and IPv6) configured, on the router or on the computer?
       
    2. Where do you want to become OpenDNS effective on the Android device, at home in the WLAN, or outside in other WLANs or when connected mobile to cell phone networks?
      Generally you should know that OpenDNS is a service only for networks you own, not for your devices in other networks.  So running OpenDNS on a roaming Android device does hardly work.

    "deactivating IPv6 would be an option"

    That should be a last resort as it throws you technically back for 2 decades. :)

    0
    Comment actions Permalink
  • Avatar
    danio368

    OK, still searching, I came across one of your previous posts:

    https://support.opendns.com/hc/en-us/community/posts/360010390606-Android-P-Private-DNS-feature-and-Open-DNS

    and I think I understand that I cannot use Opendns with the private DNS feature in Android 9.

     

    0
    Comment actions Permalink
  • Avatar
    danio368

    Thanks again for your help. We posted at the same time. Answers to your questions:

    1.Where do you have the OpenDNS resolver addresses (IPv4 and IPv6) configured, on the router or on the computer?

    The easiest solution would be to have OpenDNS configured on a router, but I don't have a 'real' one. The 'router' I am using the one provided by my internet provider, and unfortunately changing DNS is not possible. I thus have to configure each of the devices my kids use at home.

    2. Where do you want to become OpenDNS effective on the Android device, at home in the WLAN, or outside in other WLANs or when connected mobile to cell phone networks?
    Generally you should know that OpenDNS is a service only for networks you own, not for your devices in other networks. So running OpenDNS on a roaming Android device does hardly work.

    Of course, ideal would be that OpenDNS is effective everywhere, but I realise this is not really feasible. So I would like OpenDNS to be working at home, on our wifi. My kids do not have internet access from their phone network. That will only leave public wifis not secured. Not perfect, but better than nothing. My idea is not really to ban any access to adult content (there will always be possible workaround) but to preventmy kids from accidentally ending up on adult sites when they are too young.

     

    Thanks again for your help. Searching on the forum, I realised you are the one answering everyone. Thanks so much

    0
    Comment actions Permalink
  • Avatar
    danio368

    So for my son's phone (Android 9), I have configured the private DNS using adult-filter-dns.cleanbrowsing.org. This is not Opendns, but works.

    I have now tried configuring my daughter's phone, running Android 6. I followed the setup guides, setting it to a static IP, in which I indicated 208.67.222.222, 208.67.220.220 as the DNS.

    But this doesn't work (on the welcome.opendns test page, or any adult site). Could that be related to IPv6? If so, is there any solution ?

    Thanks in advance

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    "The 'router' I am using the one provided by my internet provider, and unfortunately changing DNS is not possible."

    The solution in this case is: buy an own router and connect it to this ISP device, so that the ISP device becomes a pure modem / gateway. All end user devices connect to your own router then which should allow custom DNS, firewall rules and much more features.  This will solve most of your current problems with DNS.  And it would save you to manage each end user device.

    Maybe the ISP device is not required at all, and you can replace it by an own router.  In the country where I live ISPs must allow to connect any router which is adhering to the technical standards.

    "I have now tried configuring my daughter's phone, running Android 6. I followed the setup guides, setting it to a static IP...  But this doesn't work"

    I have also an Android 6 phone, and it works on it.  You must disable the Data Saver feature on the Chrome browser, else you will be using Google's proxy servers - and Google DNS, of course.  (I don't run Chrome on my Android 6 device and have deactivated it, but I use other browsers like Iron, so cannot provide detailed instructions.)

    "on the welcome.opendns test page, or any adult site"

    For sure, as long as the welcome page doesn't work, not any other feature can work.  The welcome page is the minimum what must work.

    "Could that be related to IPv6?"

    No, not as long as you have configured DNSv4 resolver addresses.  Btw, I do not think that Android 6 is IPv6 capable, because you cannot enter or manage IPv6 addresses and settings.

    0
    Comment actions Permalink
  • Avatar
    danio368

    I couldn't get it to work on Android 6. I deactivated IPv6, and it instantly worked. I don't really get it. But I guess I'll stick to that as I don't really need IPv6 at this point.

    0
    Comment actions Permalink

Please sign in to leave a comment.