DDNS updater getting server moved error???

Comments

32 comments

  • Avatar
    daveh6499

    Nope no go with the two urls you gave me. also tried /nic/update? 

     

    All with the same error, looks like the /nic/update? url is forwarding somewhere but not connected...

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    Here is that status error, my ip address has been xxxx out...

     

    Mon Jul 27 17:50:16 2020: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater. 
    Mon Jul 27 17:50:16 2020: I:INADYN: IP address for alias 'all.dnsomatic.com' needs update to 'xxx.xxx.xxx.xxx' 
    Mon Jul 27 17:50:17 2020: W:INADYN: Error validating DYNDNS svr answer. Check usr,pass,hostname! (HTTP/1.0 301 Moved Permanently 
    location: https://updates.dnsomatic.com/nic/update?hostname=all.dnsomatic.com 
    date: Mon, 27 Jul 2020 21:50:16 GMT 
    server: opendns 
    connection: close 
    content-length: 0 

    0
    Comment actions Permalink
  • Avatar
    eagle44

    I can confirm that on July 22 (or 23), 2020 this issue started and the configurations above were not able to update DNS-O-Matic using DD-WRT as a DDNS Updater.  Hoping it will be looked into and corrected.

    1
    Comment actions Permalink
  • Avatar
    daveh6499

    Yes definitely something going on with ddwrt and it's ddns service via inadyn. If I take the URL and open it in a browser like chrome or anything else it updates all my accounts on dnsomatic...

    0
    Comment actions Permalink
  • Avatar
    sjdvda

    I'm also having an error on a Huawei HG8245Q router since the 23rd of July. It was working without any issues for the previous 6 months or so.

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Did anybody raise a support ticket? If not, most likely nothing will change. Promised!

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    Yes I did a day ago...no word yet from opendns... might be something to do with the "opendns" login redirect that dnsomatic now uses. like I posted above if you login to dnsomatic via a browser and just enter the update url in a new page, it will update your dnsomatic account with your current ip and updates all the services you have entered into dnsomatic... looks like ddwrt's ddns inadyn service is not logging in properly or opendns is not accepting how ddwrt's ddns inadyn service is sending our user names and passwords...

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    I heard that it can take up to three weeks before a ticket is handled.

    And your guesses may be right. It also could have to do with the HTTP/HTTPS versions being used by the client and the server. They had a similar problem some time ago.

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    yes I know, I am also reading that dnsomatic has been using the opendns login for sometime now, and I am almost sure it is related to the "special character" that the opendns login password requirements needs that is not passed along using the ddwrt's ddns inadyn service.. Trying to find a "special character" that will be passed to dnsomatic/opendns login page from the ddwrt ddns inadyn service... 

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    One more thing to toss into this thread, if I change the ddns service to something else v like no-ip.com which I have my email and a password with special characters it works and updates my IP at noip.com... so I'm thinking it's a dnsomatic/opendns issue.

    0
    Comment actions Permalink
  • Avatar
    leighhaynesuk

    I am seeing similar problems with the Dynamic DNS function on my Billion router. It previously worked fine for a couple of years, but then started to fail in July. The error given is:

    ddnsd: update all.dnsomatic.com request failed. Please check the setting.

    I suspect the login changes are the cause. I've opened a support ticket.

    0
    Comment actions Permalink
  • Avatar
    glli80

    Definitely DNS-O-Matic side added some redirection mechanism when log in to update the ip address.

    0
    Comment actions Permalink
  • Avatar
    mattihah

    With my Fritz!Box i've the same problem since two week ago! (error 301, moved permanently)

    Is there someone who have tried to send a message to the assistence?

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    I did a week ago, no word from support as of yet...

    You can manually update all you services with your IP of you log into dnsomatic with a browser with the IP you want to update all your services with, then in the "update URL" in the browser and all your services on dnsomatic will have refreshed to the current ip you are on..

    0
    Comment actions Permalink
  • Avatar
    leighhaynesuk

    I opened a support call and I believe daveh6499 also did.

    However, I would recommend that everyone experiencing this issue does the same. If more people raise the issue it is more likely to be looked at. Just email support@opendns.com as detailed here:

    https://support.opendns.com/hc/en-us/articles/360037648951

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @mattihah
    I have a FritzBox where it works.

    0
    Comment actions Permalink
  • Avatar
    pixelado27 (Edited )

    i have the same problem with My asus router firmware asuswrt Merlin, this is My log
    Aug 6 03:17:16 rc_service: watchdog 322:notify_rc start_ddns
    Aug 6 03:17:16 ddns_update: ez-ipupdate: starting...
    Aug 6 03:17:16 ddns_update: connected to updates.dnsomatic.com (146.112....) on port 80.
    Aug 6 03:17:17 ddns_update: unknown return code: 301
    Aug 6 03:17:17 ddns_update: server response: Moved Permanently
    Aug 6 03:17:17 ddns_update: asusddns_update: 1

     

    I send mail to support

    Your request (#742019) has been received and is being reviewed by our support staff.

    Our tickets are answered in the order received, so to avoid delaying your response, please don’t reply to a ticket until it has been assigned to a support representative.

     

     

     

    0
    Comment actions Permalink
  • Avatar
    dauniram

    @rotblitz
    Can you share your config? If it works for you.
    Thanks regards
    Frank

    0
    Comment actions Permalink
  • Avatar
    dauniram

    ...i opened a support ticket at OPENDNS as well now. rgds Frank

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    @dauniram
    Nothing special to share, just the normal update URL. It works since years.

    0
    Comment actions Permalink
  • Avatar
    dauniram

    @rotblitz
    For me it also worked for years. But now it doesn't work anymore. Error 301 Moved Permanently
    Rgds
    Frank

    0
    Comment actions Permalink
  • Avatar
    leighhaynesuk

    I suspect some routers will handle to redirected login OK, whilst others won't. Clearly wasn't tested adequately before the change was made.

    0
    Comment actions Permalink
  • Avatar
    omatzyo

    I changed DYNDNS Server to updates.opendns.com and now everything works fine.

    1
    Comment actions Permalink
  • Avatar
    coski_dad

    Thanks omatzyo!!!!  Changing to updates.opendns.com got rid of the errors for me also - will have to watch to confirm it's actually updating, but looks good so far!

    0
    Comment actions Permalink
  • Avatar
    leighhaynesuk

    Unfortunately my router doesn't allow the host name to be changed on it's DDNS options.

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    omatzyo... Attempted to change my dyndns server to "updates.opendns.com" and I still get the same error!!! :( 

     

    on the other hand opendns support did reply to my ticket with a request of my log and they are sending it up the chain to see what's going on... 

    0
    Comment actions Permalink
  • Avatar
    glli80 (Edited )

    @coski_dad and @omatzyo,

    I am using dd-wrt, I tried changing the server to updates.opendns.com, the router is able to login successfully and shows "updated successfully". However from dnsomatic side, actually it updated nothing, still showing "Waiting for first update". Did I miss anything? what are your settings?

     

    Update:

    I just tried again with updates.opendns.com. Yes the opendns site (https://dashboard.opendns.com/settings) did update to my new ip (i used a https proxy to change to a new ip), but https://www.dnsomatic.com/ did not. The latter contains both opendns and afraid.org services, so in this way I can't update both opendns ip and ddns if my ip changes. It's not a good solution...

    0
    Comment actions Permalink
  • Avatar
    ctj (Edited )

    I, too, use DD-WRT and tried changing the server to updates.opendns.com. As @glli80 mentioned, the router gives a sign of success, but in reality nothing has changed.

    I also use DNS-O-Matic to change OpenDNS and afraid.org services. Neither one shows a change in the DOM dashboard.

    I can get them to change if I open up a browser and navigate to the updates URL.

    I emailed the general OpenDNS support (support@opendns.com) as well as the DOM support (dnsomatic@opendns.com). Hopefully responses will come quickly.

    0
    Comment actions Permalink
  • Avatar
    coski_dad (Edited )

    Agreed - I had a chance to do a similar test: change externally visible IP via web proxy and manually update DNS-O-Matic, which also updated opendns, then edited the cache file on the router to force an update.  DNS-O-Matic is NOT updated via updates.opendns.com, but opendns is.  In my case, OpenDNS is the only service I need updated, so as long as DNS-O-Matic doesn't go in and change the OpenDNS service I should be Ok until a real fix is found.

     

    Note that adding "--verbose 5" to your INADYN options will show some additional information, including that authentication is via base64 - which is perhaps key to OpenDNS's new authentication not working...

     

    ------

    EDIT: I realized that clicking the green thumb in the DNS-O-Matic control panel disables its updating of OpenDNS, so I did that and confirmed that no push happens.  (In fact updates.dnsomatic.com responds "nohost" instead of "good A.B.C.D" as normal)

    FWIW I see no noticeable delay in OpenDNS updates from when I manually fire INADYN until the change appear in my OpenDNS control panel.

    0
    Comment actions Permalink

Please sign in to leave a comment.