DDNS updater getting server moved error???

Comments

63 comments

  • Avatar
    omatzyo (Edited )

    It does update opendns, but it takes some time (for some reason).

    I agree - this is definitely not a solution for most people as it only updates opendns.  You miss out on all of the other downstream services that are touched by dnsomatic.  Ultimately opendns needs to fix this.

    -1
    Comment actions Permalink
  • Avatar
    daveh6499 (Edited )

    So a small follow up on this, I attempted to use "updates.opendns.com" for the dyndns server and I still get errors like I was when using "updates.dnsomatic.com"...

     

    But if I use "update.opendns.com" or "update.dnsomatic.com" ("updates" without the "s") I DO NOT GET the error on my ddwrt's inadyn service, and the ip change is successful as per the ddns status log. But on DNS-O-Matic side there is no change noted on any of my services added. Logged out and in of dnsomatic and still no changes!!! 

    also found out you can use ANYTHING in the dysdns server field and it will not give any errors in the inadyn status log... try "update.my.crapnow" in the server and you will see a "successful" IP change!!!

     

    SO.... Long story, short you will still have to wait for opendns/dnsomatic to fix it on there end.... Oh Well....

    0
    Comment actions Permalink
  • Avatar
    pixelado27

    my problem was solved by creating a custom script for dnsomatic on my Asus wrt Merlin, for other routers they can try to create a script with autostart

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    pixelado27:

     

    Care to share your script? without your personal info obviously... 

    0
    Comment actions Permalink
  • Avatar
    leighhaynesuk

    Received a reply from OpenDNS support today. They suggested using updates.opendns.com as already mentioned in this thread.

    Sadly this is not an option on my router and from what others have said, doesn't help anyway.

    Hopefully this means they are looking at the problem now.

    0
    Comment actions Permalink
  • Avatar
    kylehase

    Hi. I believe I've found the root cause and workaround.

    According to this German forum, the issue is that DNSomatic implemented a 301 redirect from http to https which the ddns client does not support.

    A workaround using DDWRT is to use cron and wget to ping a custom URL. The Cron field can be found under Administration > Management > Cron and full command would look something like this:

    0 0 * * 0 wget https://<URL encoded email>:<pass>@updates.dnsomatic.com/nic/update?hostname=<hostname>

    The email must be URL encoded to convert the @ symbol to %40 or it will break the URL. You may also need to URL encode the pass depending on characters used. 0 0 * * 0 will run the update weekly on Sunday at midnight. If your cron-fu is rusty, this tool may help https://crontab.guru

     

    0
    Comment actions Permalink
  • Avatar
    dauniram

    The German forum says that we should use https instead of http for the update command. But with my Fritzbox 7490 https doesn't work. rgds Frank

    0
    Comment actions Permalink
  • Avatar
    pixelado27

    sure, this is the script that worked for me

    #!/bin/sh
    # Update the following variables:
    USERNAME=dnsomatic_username
    PASSWORD=dnsomatic_password
    HOSTNAME=all.dnsomatic.com

    # Should be no need to modify anything beyond this point
    /usr/sbin/curl -k --silent -u "$USERNAME:$PASSWORD" "https://updates.dnsomatic.com/nic/update?hostname=$HOSTNAME&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG&myip=$1" >/dev/null 2>&1

    if [ $? -eq 0 ]; then
    /sbin/ddns_custom_updated 1
    else
    /sbin/ddns_custom_updated 0
    fi

    0
    Comment actions Permalink
  • Avatar
    muadeep

    Pixelado 27,

     

    In the script that you propose is for updating everyday?

     

    thanks in advance,

    Muadeep

    0
    Comment actions Permalink
  • Avatar
    pixelado27 (Edited )

    yes,  this script has worked for me and it updates the IP, you have to give it auto-start permissions so that in case of restarting the router it starts automatically

    0
    Comment actions Permalink
  • Avatar
    muadeep

    Dear Pixelado,

     

    Thanks for the answer but I would like to know if the updates with your script is daily in the router or in how much time?

     

    Thnaks,

    Muadeep

    0
    Comment actions Permalink
  • Avatar
    desktopguy

    Hi all,

     

    I also noticed this - it took a while as I redirect the updated subdomain to an internal IP so didn't notice straight away.

    For me the resolution was switching from http url to https url of dnsomatic.

    I think the DDNS updaters built into routers are using only http!!

    I have used the http method for around 4 year perfectly till last month when it stopped.

    I'm updating dnsomatic via a Draytek router as DDNS client.

     

    For the record the correct settings are;

     

    Provider host: updates.dnsomatic.com

    Service API: /nic/update?hostname=

    Connection Type:  https

    Login Name:  (dnsomatic username)

    Password: (dnsomatic password)

     

    0
    Comment actions Permalink
  • Avatar
    pixelado27

    muadeep
    updates are forced to be done daily

    0
    Comment actions Permalink
  • Avatar
    diogo-cvs

    DD-WRT

    • Create an ext4 partition with the label "Optware"
    • Enable:
    1. Core USB Support
    2. USB Storage Support
    • Install Entware:

    https://github.com/Lanchon/ddwrt-secure-entware

    • Install the newest version of inadyn:

    opkg update && opkg install inadyn

    • Create the configuration file:

    /opt/etc/inadyn.conf
    period = 300
    forced-update = 864000
    iface = vlan2
    provider default@dnsomatic.com {
      username = OPENDNS_USERNAME
      password = OPENDNS_PASSWORD
      hostname = all.dnsomatic.com
    }

    • Configure a startup script:

    #!/bin/sh
    sleep 10
    if [-f /opt/generic.sh]; then
      cd /tmp/root
      ln -s /opt/root/.profile
      ln -s /opt/root/.inputrc
      ln -s /opt/root/.config
      /opt/etc/init.d/rc.unslung start
    fi

    • Configure a shutdown script:

    #! /bin/sh
    if [-f /opt/generic.sh]; then
      /opt/etc/init.d/rc.unslung stop
    fi

    • Adjust the log:

    /opt/etc/init.d/S52inadyn
    ARGS = "--loglevel info"

    • Reboot router
    • Check the log /var/log/messages

    Aug 19 13:04:23 DD-WRT user.info inadyn [21535]: Checking for IP # change, querying interface vlan2
    Aug 19 13:04:23 DD-WRT user.info inadyn [21535]: No IP # change detected for default@dnsomatic.com, still at x.x.x.x

    0
    Comment actions Permalink
  • Avatar
    daveh6499

    ok, received an email from t2 opendns support, suggest I use port 443 to send the "updates.dnsomatic.com" instead of port 80... 

     

    Now on to how to figure out how to do that with my ddwrt inadyn ddns service.... Anyone???

    0
    Comment actions Permalink
  • Avatar
    diogo-cvs

    Update the inadyn, as the previous post.

    0
    Comment actions Permalink
  • Avatar
    daveh6499 (Edited )

    diodo-cvs... I am not too versed with what looks like linux, thats a bit over my head at the moment....

     

    Trying to look into the simple ddwrt-wiki fix for secure ddns updates at the bottom of the page...

    https://wiki.dd-wrt.com/wiki/index.php/DDNS_-_How_to_setup_Custom_DDNS_settings_using_embedded_inadyn_-_HOWTO#Secure_DDNS_Updates_Over_HTTPS.2FSSL

    0
    Comment actions Permalink
  • Avatar
    ctj

    I posted about this in the DD-WRT forums here: https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1215324&sid=6355c10b6d8f2d46009895d1aaf0805d#1215324 

    The support people got a hold of me today as well. All you have to do is add the port number to the URL and it should work. Here's how mine is setup now, working as expected:

    6
    Comment actions Permalink
  • Avatar
    glli80 (Edited )

    I confirm ctj 's method works on my dd-wrt router. Thanks, ctj!

    I believe this is a simple fix and the final solution. 

    Actually I tried changing the URL box content to "https://updates.dnsomatic.com/nic/update?hostname=" a few weeks ago but it didn't work. I didn't expect that https protocol still needs to explicitly specify 443 port, lol.

    2
    Comment actions Permalink
  • Avatar
    daveh6499 (Edited )

    yes!!! adding the port to the url worked for me also, at 1st i was url encoding my opendns user name "email address" with "%40" and also encoding the ":" with "%3A" but I just entered everything without the encoding and it works!!!

    also make sure that this is in the url box

    https://updates.dnsomatic.com:443/nic/update?hostname=

    Thanks to all for the help...

    2
    Comment actions Permalink
  • Avatar
    coski_dad

    Thanks CTJ!  I'm back to using dnsomatic with the https and :443 trick!

    0
    Comment actions Permalink
  • Avatar
    jk4287

    Thanks CTJ! It works like a charm!

    0
    Comment actions Permalink
  • Avatar
    muadeep

    Thanks CTJ! It works great at  LAST!

    0
    Comment actions Permalink
  • Avatar
    fikoullimakan

    That's what worked form me, see hostname :

    Note :
    - I'm on DD-WRT v3.0-r40559 std (08/06/19)
    - I have only opendns account on dnsomatic.com

    0
    Comment actions Permalink
  • Avatar
    leighhaynesuk

    My Billion router doesn't have an option to change the URL. However, the Billion engineering team have released updated firmware for several of their routers to fix this breaking change made by OpenDNS.

    OpenDNS on the other hand did nothing to help.

    0
    Comment actions Permalink
  • Avatar
    marcodome

    @dauniram
    For Fritz!Box: I opened a case with AVM support and I discovered that actually it's enough to change the URL configuration from

    updates.dnsomatic.com/....
    to
    https://updates.dnsomatic.com/...

    It seems that Fritz!Box does support https but it does not support the redirect from http to https...

    0
    Comment actions Permalink
  • Avatar
    AccurateLAN

    ctj:

    THANK YOU!!!!!  This was driving me NUTS!

    DD-WRT 4-EVA!!!

    0
    Comment actions Permalink
  • Avatar
    AccurateLAN

    ctj

    See previous post. Oops.

    0
    Comment actions Permalink
  • Avatar
    coski_dad

    Broken again as of at least September 2021?

     

    Fri Sep 24 21:09:49 2021: W:INADYN: Response Code: 1
    Fri Sep 24 21:09:49 2021: W:INADYN: Error validating DYNDNS svr answer. Check usr,pass,hostname! (HTTP/1.0 403 Forbidden
    content-length: 9
    content-type: text/plain
    date: Sat, 25 Sep 2021 03:09:48 GMT
    server: opendns
    connection: close

    Forbidden)

    0
    Comment actions Permalink

Please sign in to leave a comment.