OpenDNS working but not recognized and not filtering.

Comments

2 comments

  • Avatar
    rotblitz (Edited )

    It seems an app, your router or most likely your ISP redirects your DNS queries to Cogent Communications.  Start with calling your ISP to opt out from this redirection.

    "Wireshark shows only communication to 208.67.222.222."

    This means nothing.  The interference happens after the point where Wireshark gets the packets from.

    0
    Comment actions Permalink
  • Avatar
    ryanmichael2 (Edited )

    I had the exact same problem.  First, check and see if your router has an option for DNS Relay and uncheck it.  Reboot and see how it works.

    If that doesn't do it, you will also (along with turning off DNS relay) have to add some firewall rules to your router.  I have posted a pic of my configuration.  Basically, instruct your LAN to get DNS only from OpenDNS on port 53 (DNS) by blocking all requests to your router for DNS info and allowing only OpenDNS on port 53.  

    Flush your DNS (Ipconfig /flushdns) in command prompt (if using windows).

    Hope this works for you too!

    **** I found out later that if you want local DNS to function correctly, ignore the last rule.

    0
    Comment actions Permalink

Please sign in to leave a comment.