DNS-O-Matic script with all.dnsomatic.com as hostname returns "nohost" error

Comments

4 comments

  • Avatar
    rotblitz

    You did not configure to update through DNS-O-Matic, but directly to OpenDNS. If you want to go through DNS-O-Matic, then the update URL is:

    https://updates.dnsomatic.com/nic/update?hostname=all.dnsomatic.com
    or
    https://updates.dnsomatic.com/nic/update

    If you want to update OpenDNS directly, then the update URL is:

    https://updates.opendns.com/nic/update?hostname=YOURNETWORKLABEL

    1
    Comment actions Permalink
  • Avatar
    balaji.dutt (Edited )

    rotblitz Thank you for the tip. Changing the update URL did indeed solve the "nohost" problem!

    Unfortunately, now it appears that there is some issue between DNSOMatic and CloudFlare. I keep getting a "err Invalid request headers (6003)" message when I try to update my CloudFlare DNS entries.

    I don't think it's a API key issue as I've regenerated it and have verified on my local machine using the CF API that the API key is valid and I can update the DNS Record correctly.

    Any ideas?

    0
    Comment actions Permalink
  • Avatar
    rotblitz

    Sorry, I am not able to help with the CloudFlare issue. Maybe another user or a support ticket with OpenDNS may help.

    0
    Comment actions Permalink
  • Avatar
    balaji.dutt

    rotblitz Turns out the issue is that you cannot use a specific API key with DNSOMatic. You have to provide the CloudFlare global API key in the DNSOMatic settings. Once I used the global API key, it started working correctly.

    1
    Comment actions Permalink

Please sign in to leave a comment.