OpenDNS not working correctly / OpenDNS Updater v2.2.1 no internet

Comments

8 comments

  • Avatar
    rotblitz

    You got the wrong IPv6 DNS addresses. These do not filter. Change these to ::ffff:d043:dedc and ::ffff:d043:dcde

    Also, consider to use the DDNS function of your router instead of the Updater.

    0
    Comment actions Permalink
  • Avatar
    nagasechi

    Thank you. For now it is working. 
    I have tried setting up my router with no-ip. And have added them to DNS-O-Matic. 

    My router still hasn't updated no-ip but I will wait until tomorrow maybe that just happens when the ip is getting changed. But do i still need an updating software for DNS-O-Matic or is it enough when my server sends the new IP to no-ip and then it will automatically update my OpenDNS-Home-Network IP?

    screenshot from dns-o-matic

     

    And when I need an updating software for dns-o-matic is there a recommendation? The website for Marcs Updater which I found seems to be down. 

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    The DDNS function of your router is the updating software against DNS-O-Matic. Nothing else is needed.

    The parameters are:
    Service: user defined
    Update URL: https://updates.dnsomatic.com/nic/update?myip=<ipaddr>
    Domain name: your no-ip hostname
    Username and PW: from DNS-O-Matic

    0
    Comment actions Permalink
  • Avatar
    nagasechi

    That didn't work for me. I searched around and now my settings in the Fritz Box are:

    Service: user defined
    Update URL: updates.dnsomatic.com/nic/update?myip=<ipaddr>
    Domain name: all.dnsomatic.com
    Username and PW: from DNS-O-Matic

    But that also didn't work and maybe it is because of my password. I tried different once but they all need special character and I do not know which one are reserved by HTML. 

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    Domain name all.dnsomatic.com will not work, because it does not exist, and your router will run amok. See the router log.

    Change your password to contain only letters, numbers, dash, dot and underbar.

    0
    Comment actions Permalink
  • Avatar
    nagasechi (Edited )

    So I changed the password, but it seems to still not update. 

    Service: user defined
    Update URL: updates.dnsomatic.com/nic/update?myip=<ipaddr>
    Domain name: my no-ip hostname
    Username and PW: from DNS-O-Matic

    At No-Ip I get the messag to configure my host address and choose my router and a software?

    When I try the OpenDNS Updater now that at least works so I can refresh the IP when I started my PC but having it done automatically by the router would be the best of course. 

     

    0
    Comment actions Permalink
  • Avatar
    rotblitz (Edited )

    I ran out of ideas. It works on my FritzBox. But I do not use no-ip, but DuckDNS. Raise a support ticket, link “Submit a request” above.

    0
    Comment actions Permalink
  • Avatar
    nagasechi

    Okay. Thank you for all the help. :)

    0
    Comment actions Permalink

Please sign in to leave a comment.