OpenDNS not working, after clearing the browser cache, restarting network card. (ISP's modem behind my router)

Comments

2 comments

  • Avatar
    bartmok17 (Edited )

    I contacted my ISP. They said that even If I had access to the administrative panel in the modem I couldn't change the DNS server, only the basic settings like SSID, enabled 2.4G / 5G Wi-Fi Networks, Wi-Fi password

    Also, now that I check to set this up on the Windows control panel, Internet Access is lost.

    When I set the 8.8.8.8 DNS server on the Windows machine's control panel, the issue disappears, but when I set the OpenDNS IP, it is lost as I said

    But, When I try to fix the internet connection and set the dns ip to 8.8.8.8 on the router, the issue is not fixed!

    Also, there's always an orange light signal on the router, even if the router settings doesn't point to OpenDNS:

    I slowly realize that It's not OpenDNS fault, but are there any hints I can get from you guys? :/ Is setting up Pi-Hole a working alternative?

     

    EDIT:

    After a Factory Reset, It seemed that Primary and Secondary DNS Servers were automatically assigned to:

    Are these the only ones accepted by the ISP modem? The light is now green!

    Then when I'm switching to another DNS I got no Internet :/ When I provide it on only Primary and left the Secondary untouched, then blocking with OpenDNS does not work

    And as I asked previously - Is there a way to talk this through and solve the problem with the ISP, or is changing ISP the only option?

    EDIT 2:

    I switched back to the Linux machine and taken a look into a resolv.conf file. It had following contents:

    is the dns address after 'search' keyword the actual dns that needs to be resolved from the default DNS Server? 

    PS. Changing nameserver's ip address results again with no Internet access

    0
    Comment actions Permalink
  • Avatar
    bartmok17 (Edited )

    SOLVED,

     

    The cause of this issue is that I was putting my own IP address (instead of OpenDNS nameservers - 208.67.222.222, 208.67.220.220) as my DNS Server.

    It's a really stupid mistake, sorry guys! 

     

    To be honest I don't know If I should delete this post. Maybe it'll become handy  for someone.

    0
    Comment actions Permalink

Please sign in to leave a comment.